FJ80 Fuel Pressure...any thoughts?

Joined
Apr 15, 2005
Messages
297
Location
Everywhere in Polk County!
I just purchased a severly neglected (mechanically) FJ80...cosmetically, it's perfect, so my wife's happy. Anyhow, having starting issues as most do...but for now, my electrical problems have been tamed...I do plan on upgrading everything on the engine in the future however from wiring harness to starter and all in between.
For now, i am afflicted with uneven fuel pressure. I have alreadly dismounted the fuel tank & cleaned it out completely twice because of the severe deposits crusted to its inner walls...I've replaced the fuel pump, fuel filter, and have been running SUPER PREMIUM FUEL ONLY to hope that i can keep from replacing the injectors along with all the lines! All that is left is the fuel sending unit, which i've actually already ordered from YOTA. Seeing how the gas gauge doesn't work due to this device anyways, it needs replaced. But I believe that since it can't produce the proper pressure because it doesn't actually know how much fuel is in the tank. This problem starting occurs especially after fueling up at the station...after it sits for about an hour, it'll start right up though. Go figure, it's still full of problems beyond this. Any thoughts would be appreciated.
Urban Trail Series Cruisers
 
Joined
Aug 28, 2003
Messages
348
Location
Pearland, TX
 
 
 
PolkLandbruiser said:
I just purchased a severly neglected (mechanically) FJ80...cosmetically, it's perfect, so my wife's happy. Anyhow, having starting issues as most do...but for now, my electrical problems have been tamed...I do plan on upgrading everything on the engine in the future however from wiring harness to starter and all in between.
For now, i am afflicted with uneven fuel pressure. I have alreadly dismounted the fuel tank & cleaned it out completely twice because of the severe deposits crusted to its inner walls...I've replaced the fuel pump, fuel filter, and have been running SUPER PREMIUM FUEL ONLY to hope that i can keep from replacing the injectors along with all the lines! All that is left is the fuel sending unit, which i've actually already ordered from YOTA. Seeing how the gas gauge doesn't work due to this device anyways, it needs replaced. But I believe that since it can't produce the proper pressure because it doesn't actually know how much fuel is in the tank. This problem starting occurs especially after fueling up at the station...after it sits for about an hour, it'll start right up though. Go figure, it's still full of problems beyond this. Any thoughts would be appreciated.
Urban Trail Series Cruisers
What are the symotoms? Have you checked pressure throughout the system (e.g. out of tank, at filter, etc)? What are the results? Where is the pressure drop at? Does it stall/die when driving a while? Getting fuel then not getting fuel?
 

landtank

SILVER Star
Joined
Mar 27, 2003
Messages
19,834
Location
Groveland MA
 
 
 
Have you gone through the EFI relay circuit. It's a known problem and tends to act up more when the vehicle is hot. Also the fuel regulator on the rail has been known to cause issues.
 
Joined
Mar 28, 2003
Messages
1,457
Location
Somewhere in NJ
 
 
What year is your 80? You might want to include truck details in your sig line; it helps folks in responding.

I too would suspect your FPR if in fact you're suffering from low pressure, but I'd stop throwing money at it until you really know what the problem is.

I also don't think running premium fuel is going to clean out your injectors--for that just use injector cleaner. You probably also need a good throttle body cleaning.

You probably don't need a new starter--just the contacts and plunger. There's a writeup on it in the tech section or on SOR's site. Call CDan at American Toyota (click on banner at top or look in vendor section) for the parts and sage advice. Dan is the local parts geek and great prognosticator of all things LC. :D

Oh...and welcome to the forum :flipoff2:
 
Joined
Apr 15, 2005
Messages
297
Location
Everywhere in Polk County!
The 80 is a 1992...I already cleaned the throttle body, and i already used injector cleaner. Besides, it's a known fact that the stock started is undergeared for the 3FE in the 80's, so i know an upgrade will help. Fuel pressure also fluctuates while driving, but not to the point it cuts off unless idling at a stoplight. Sometimes while idling the battery voltage will plunge and I have to brake/gas simultatneously or throw it into neutral. The EFI relay circuit was replaced recently before I purchased the 80 and I've tested it to ensure it works properly still. The pressure drops at all points of the system, leading me to believe the beginning is the start of the problem. My FSU/G came in today, so I'll be installing it and will let ya's know if it fixed my dilemma.
Thanks
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom