FJ62 engine suddenly dies

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Joined
Mar 10, 2006
Threads
117
Messages
343
Location
Dallas/Ft. Worth, TX
My friend's 1988 FJ62 daily driver has been acting up lately and we can't find the problem. This has 238,000 miles on the clock and has been reliable for years. Occasionally the engine will start running rough then die. But it starts right up with no problem. Occasional spark knock heard just driving on smooth level pavement . No check engine light and no codes stored in computer. Fuel pump, fuel filter, and mass air flow sensor have been replaced but problem persists.
O2 sensors have never been replaced.
Any ideas where to look?
 
By spark knock I mean the pinging you hear when you're timing is too far advanced or your fuel octane is too low. Fuel pump is new and pressure was good. This thing will go days without a problem then die. Engine hot or cold it doesn't matter.
 
By spark knock I mean the pinging you hear when you're timing is too far advanced or your fuel octane is too low. Fuel pump is new and pressure was good. This thing will go days without a problem then die. Engine hot or cold it doesn't matter.
ok start think about you egr valve, and all of the vac hoses, i think you will find your trouble there:beer:
 
Ignition module???
 
I thought ignition modules either worked or didn't work - nothing intermittent. This thing just dies, but starts up immediately then runs just fine.
 
this happened to our 62 about 5 years ago leaving the wife stranded at the grocerie store - ended up being that the dizzy died. Have you pulled the dizzy cover and looked for a bad rotor or carbon tracks on the inside of the cover?
 
I thought ignition modules either worked or didn't work - nothing intermittent. This thing just dies, but starts up immediately then runs just fine.

Like any electrical part, sometimes they can just start going schizo, especially after they heat up. Just had one a few days ago on a Chev V-6 that would run great for about 10 minutes, then act like it was running out of gas, start backfiring and die. A few mins later would fire right up and run good for a couple minutes, then start doing it again. After going thru the fuel system and finding nothing, I threw in a module, problem gone. As it would heat up the timing was going all out of whack and wasn't firing properly.
 
Today the FJ62 engine quit headed down the highway at 60 mph. Shifted into neutral and it started right up and never missed a beat after that. Sounds more like GREMLINS than an ignition module.
 

Users who are viewing this thread

Back
Top Bottom