First Fluid change in the Orion........

wngrog

SILVER Star
 
 
 
Joined
Feb 10, 2002
Messages
29,992
Location
Canton, Mississippi
......Poser is the man. Neither fill or drain plug had more shavings than that that was around the little groove around the magnet. VERY little metal.

Fluid was as clear as the day I stuck it in there.

Poser is the man!
 
Joined
Jan 22, 2003
Messages
8,121
Location
Kansastitty
Nolen, did he send you a ready-to-bolt-up deal with a tranny? That's what I've been talking to him about. Steve is a great guy, and has helped me a lot. Glad to hear about your lack o' metal!
Oh, and what transmission?

Ed
 

haystax

 
Joined
Mar 9, 2004
Messages
1,264
Location
Diamond Valley, Nevada
So what serial number is yours? The issues with Treeroot et al early cases seem to be solved? What is your transmission setup now - stock 4spd? Stays in gear, works fine then?

Good to hear something good about the Orion - I might have to get one this fall
 

wngrog

SILVER Star
 
 
 
Joined
Feb 10, 2002
Messages
29,992
Location
Canton, Mississippi
Mine is an early model, before they started the pre-assembly, that has to be unassembled :rolleyes:

I sent Steve my case and he built my Orion.

I bolted it to a stock H42.

If you run 37's or smaller, with 4.11's that is PLENTY of gearing.

Poser is the man.
 
Joined
Sep 20, 2004
Messages
2,407
Location
here
cool , I flogged mine thru a wet , snowy rubicon and it did a fabulous job. Love the gears. Snow and 3rd gear in low range makes for some fun.....
 
Top Bottom