faulty cdl

Jerome3

 
Joined
Apr 19, 2005
Messages
186
Location
San Francisco, CA
Amidst my failures today i did happen to install my cdl switch and do the pin7 mod, yet this was amidst my failures. after installing the cdl switch the indicator ligths would not light up and cdl would not lock, i checked the switch again and again and seemed to be connected fine so i checked to see if it would lock when placing the trans in low (prior to doing the pin7 mod) and no such luck. after seeing this i proceeded to complete the pin7 mod and was successful as the cdl still does not engage in low :grinpimp: . are there any common reasons for the cdl not to engage.
 
Joined
Jan 11, 2005
Messages
557
Location
Poulsbo, WA
I know the first time I installed my switch the CDL light did not come on and neither did the ABS light. I tried plugging the terminating wire plug back and and putting it in lo did not work.. which I knew it had worked before. So I cleaned the contacts of the switch and the dash plug. After that it worked fine, as it had me scared for a second there. Assuming you have seen the CDL engage/light come on and ABS light come on when engaging low gear, try cleaning the contacts for now.
 
Joined
Mar 29, 2005
Messages
48
look the cdl switch will activate when you drive and turn right or left in a off road like sand . you also should hear the switch click when you press it on.
 
Joined
Sep 28, 2004
Messages
416
Location
West Wales UK
Most DL need some differential to allow things to mesh before engaging so it is best to try things either on the loose or with one wheel on each axle jacked up for the proposes of investigation.

With the engine off but ignition on operate the CDL switch; a clicking noise coming from the relay in the foot well should be apparent when you switch the CDL switch off and on. I f you have not don the 7pin mod then the same should be true when shifting in and out of Low Ratio.

If the relay is operating have an assistant operate the CDL switch while you are under the truck (engine off ignition on as we do not want to send any flowers to your wife) as the CDL switch is operated a burring sound should be heard as the CDL Actuator Motor operates as it tries to engage the diff lock. The actuator is situated on the top rear of the transfer box near the output.

If no noise is apparent from the actuator locate the switch at the top RHS of the transfer box remove the plug and unscrew the switch, test it with a meter to se if it is working if not replace it. You can short out the harness to se if any thing works.

If nothing then works the actuator will need removing cleaning and checking out, the Slee site shows this.

http://www.sleeoffroad.com/technical/tz_diff_lock_actuator.htm

If you do a search there are some references to this problem and will find some under my name. My CDL operates immediately when coming on but may require just a little thought when disengaging but then I live off road and things get used regularly Good luck.
 
Top Bottom