f**K!!!

Discussion in '60-Series Wagons' started by hammer1, Aug 8, 2005.

  1. hammer1

    hammer1

    Messages:
    791
    Likes Received:
    2
    Joined:
    Feb 11, 2005
    Location:
    morristown nj
    my smog pump froze up Saturday, and the guy cant do it untill Wed., and Im leaving for Vacation this Saturday.
    Im trying Metro Land Cruisers in Montclair NJ. recomended my
    Jman.
    If i had time , id do it myself.
    I'll let everyone know how it turns out.
    thanks for letting me rant
    Hammer
     
  2. Fearnofish!

    Fearnofish!

    Messages:
    260
    Likes Received:
    0
    Joined:
    Jun 7, 2005
    Location:
    Hamilton, MT
    Took me 1 hour to remove mine, gut it, and replace the shell.
    Good Luck
     
  3. hammer1

    hammer1

    Messages:
    791
    Likes Received:
    2
    Joined:
    Feb 11, 2005
    Location:
    morristown nj
    i thought of that, but in NJ, it wouldnt pass the smog test.
     
  4. polarweasel

    polarweasel Where's mah cruzah?

    Messages:
    991
    Likes Received:
    2
    Joined:
    May 6, 2004
    Location:
    Vancouver Island, BC
    And are you going to be taking a smog test before your vacation...?

    If not, why don't you just gut it and put in a new one later?
     
  5. hammer1

    hammer1

    Messages:
    791
    Likes Received:
    2
    Joined:
    Feb 11, 2005
    Location:
    morristown nj
    no time, and im not kidding. i get home from work at 6:00pm, and work on the house untill midnight.
    took on a big reno job this summer, thinking id get it done, being my wife is a teacher, and home from school for the summer, therefor letting me get some time to do things ( ie, the smog pump)
    i was wrong, dead wrong.
    hammer
     
  6. swank60

    swank60

    Messages:
    1,484
    Likes Received:
    244
    Joined:
    Aug 26, 2002
    Location:
    One of Four Presidential Flying Saucers
    You need to find out why yours crapped out, otherwise the replacement is going to do the same thing. I remeber you saying that the hose from your air rail was burned out when you worke on your PS pump. Have the shop check the check valve - sounds like you've got hot air pushing back into the pump. That could be one source of your failure.

    If your PS pump was leaking on it, that was probably one of the contributors, too. At least your made it over 200k miles...
     
  7. 60wag

    60wag SILVER Star

    Messages:
    1,929
    Likes Received:
    44
    Joined:
    Jun 25, 2003
    Location:
    Boulder, CO

    You too huh? I'm nearing the end of my renovation project. I haven't spent a weekend outside playing sinc the summer started. I'm looking forward to having some time to spend on my truck. I'm close to being able to clear out the garage so it will actually fit inside again.

    Seriously, tempoarily gutting the pump to make a trip shouldn't take more than 2 hours. Good luck.
     
  8. lowtideride

    lowtideride

    Messages:
    7,611
    Media:
    12
    Albums:
    1
    Likes Received:
    83
    Joined:
    Sep 29, 2003
    Location:
    The Sunshine State
    cant you just pull the belt of the smog pump and run it around your alt.,water pum and crank? if ya dont have huge tires driving with out ps should not be too bad...
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.