Diagnosis this leak! (It’s probably the knuckle though) (1 Viewer)

Joined
Aug 2, 2020
Messages
194
Location
Bay Area Ca
Long story short I’ve had my knuckles rebuilt not more than a few months ago and everything was fine. Fast forward to a few weeks ago I heard some squeaking coming from the front drive shaft or wheels....didn’t think much of it until I was installing some sliders the other day and saw this while
under the rig.

F22135B8-C77F-4D94-9A1C-25A4E97DC8BE.jpeg

F1901E00-60B2-42CF-8291-853403D8182A.jpeg
D114D074-5AA9-4B52-AC21-FD0537ED006A.jpeg
F675B031-3608-45CC-BE46-FCCCBDD1D11E.jpeg


4A1FB365-5E7E-47F5-9D9D-3941372CC065.jpeg
 
Joined
Nov 9, 2012
Messages
10,847
Location
Olathe, KS, USA
Long story short I’ve had my knuckles rebuilt not more than a few months ago and everything was fine. Fast forward to a few weeks ago I heard some squeaking coming from the front drive shaft or wheels....didn’t think much of it until I was installing some sliders the other day and saw this while
under the rig.

View attachment 2646529
View attachment 2646530View attachment 2646532View attachment 2646533

View attachment 2646531
It looks like they did not put ANY grease in the ball/knuckle cavity, as there is no buildup.

They may have filled with gear oil like the old school Dana axles and that is COMPLETELY wrong for these.

1) Take it back and have them do it right.
2) You need moly grease in the ball knuckle
3) Make sure they clean your axle housing vent and fitting to make sure that it doesn't blow out your inner axle seal.
4) Consider a new mechanic if they don't know how to work on these.
5) Check your differential oil level before driving it back, because if it's low, you may smoke your differential bearings.
6) Squeaking means they probably toasted your spindle bushings
7) This much oil (or maybe lack of oil) may have even destroyed your wheel bearings, as your front wheel bearings are not designed to operate in oil and the oil does not have a "cavity" to retain it in the hub.
 
Joined
Aug 2, 2020
Messages
194
Location
Bay Area Ca
UPDATE: first off thanks everyone that sent messages and input! Def armed me with some
Info taking the rig back into the shop! So they had rebuilt the knuckles w a trail gear kit.... they said apparently the seals melted on both sides and began to leak.... I for one can see perhaps a faulty single seal but two?! The odds seem low to me on that front but if anyone has heard of this so let me know.... that said they rebuilt both knuckles entirely w factory Toyota parts... so we’ll see.... thanks again y’all! 🙏 !!
 
Joined
Dec 10, 2007
Messages
7,653
They said the axle seals (or knuckle wipers?) melted?? Did the shop charge you full price for the second job?
 
Joined
Feb 16, 2012
Messages
203
How can they say only Toyota parts used and then do a job like that..and then to say the seals melted. They clearly have no clue what they are doing. Also I know yours was trailgear.

I’m also amazed you found someone to work on it. The mechanics around me won’t touch mine because it actually requires real work.
 
Joined
Aug 2, 2020
Messages
194
Location
Bay Area Ca
They said the axle seals (or knuckle wipers?) melted?? Did the shop charge you full price for the second job?

axle seals... and hell no they didn’t charge me! They clearly messed up something didn’t admit it and bought the replacement parts at their expense and fixed the issue free of charge...
 
Joined
Aug 2, 2020
Messages
194
Location
Bay Area Ca
How can they say only Toyota parts used and then do a job like that..and then to say the seals melted. They clearly have no clue what they are doing. Also I know yours was trailgear.

I’m also amazed you found someone to work on it. The mechanics around me won’t touch mine because it actually requires real work.
How can they say only Toyota parts used and then do a job like that..and then to say the seals melted. They clearly have no clue what they are doing. Also I know yours was trailgear.

I’m also amazed you found someone to work on it. The mechanics around me won’t touch mine because it actually requires real work.

How can they say only Toyota parts used and then do a job like that..and then to say the seals melted. They clearly have no clue what they are doing. Also I know yours was trailgear.

I’m also amazed you found someone to work on it. The mechanics around me won’t touch mine because it actually requires real work.

they are on off road only shop so they should know how to do this work.... and they have a lot of Yotas as well... but not many 80s from what I’ve seen. I alao know their main tech / mechanic didn’t do the original job himself and he had to clean up someone’s mess and fix the issue....
 
Joined
Oct 27, 2020
Messages
37
Location
80214
I used a trail gear kit on my last rebuild and it's leaking already with no more than 5k miles on the rebuild. I'm going oem inner axle seals next time and bought the seal driver from wit's end
 
Joined
Nov 9, 2012
Messages
10,847
Location
Olathe, KS, USA
UPDATE: first off thanks everyone that sent messages and input! Def armed me with some
Info taking the rig back into the shop! So they had rebuilt the knuckles w a trail gear kit.... they said apparently the seals melted on both sides and began to leak.... I for one can see perhaps a faulty single seal but two?! The odds seem low to me on that front but if anyone has heard of this so let me know.... that said they rebuilt both knuckles entirely w factory Toyota parts... so we’ll see.... thanks again y’all! 🙏 !!
Trail Gear parts are NOT Toyota parts.
 

LandLocked93

SILVER Star
Joined
Jun 11, 2018
Messages
644
Location
Colorado
UPDATE: first off thanks everyone that sent messages and input! Def armed me with some
Info taking the rig back into the shop! So they had rebuilt the knuckles w a trail gear kit.... they said apparently the seals melted on both sides and began to leak.... I for one can see perhaps a faulty single seal but two?! The odds seem low to me on that front but if anyone has heard of this so let me know.... that said they rebuilt both knuckles entirely w factory Toyota parts... so we’ll see.... thanks again y’all! 🙏 !!
I don't see a bit of moly leaking. It all looks diff oily. Or oil in the knuckle where there should have been moly grease.
So the question is did the shop actually use moly in the knuckle on the second go'round?
 
Joined
Aug 2, 2020
Messages
194
Location
Bay Area Ca
Th
I don't see a bit of moly leaking. It all looks diff oily. Or oil in the knuckle where there should have been moly grease.
So the question is did the shop actually use moly in the knuckle on the second go'roun
I don't see a bit of moly leaking. It all looks diff oily. Or oil in the knuckle where there should have been moly grease.
So the question is did the shop actually use moly in the knuckle on the second go'round?

that was my exact thought too.... they “said” the seals melted (which they may have) but it was probably leaking diff oil bc they didn’t originally use Molly grease to begin with! They replaced everything “free of charge” bc they knew they f***ed up! Either way I made sure they did it proper the second time around. Spoke to the owner of the shop etc (whom actually did the work the second time around). Either way it’s corrected and ok good to go.
 

Users who are viewing this thread

Top Bottom