CSI Fridge/ Freezer (1 Viewer)

Joined
Aug 9, 2015
Messages
385
Location
Turquoise Trail, New Mexico
I love mine, has been working great for about a year now. Tough as well, we traveled over 3k miles last year with hundreds of off road miles , some extremely rough washboard roads in Death Valley that shook our brains loose. The fridge supported a family of 4 great for up to 3 weeks at a time, great buy! or you could spend 500 for the A, 500 for the R, and another 500 for the B! Thanks mike, I've been spreading the word.
 
Joined
Oct 14, 2009
Messages
80
Location
Hoquiam, Wa
I just picked one up today and it’s giving me F1 error. It won’t run for more than about 30 seconds with the rig off. It’s reading 12.5 v while sitting and shut off. It’s set to H.

Do I need to drop that to M? It’s on a brand new battery. Do I need a solar setup to give it more power? It’s 90 degrees outside, but I got it nice and cold before installing it into my rig.
 
Joined
Apr 3, 2008
Messages
141
Location
Grants Pass Or.
I would put the power settings to M. High is only good when the vehicle is running ie 13 plus volts. Low is good for dedicated battery. We also now have small battery packs you can use in your rig that will run the fridge for 8 hrs at a time and can be used as a pass though or in conjunction with a vehicle battery.
 
Joined
Oct 14, 2009
Messages
80
Location
Hoquiam, Wa
I would put the power settings to M. High is only good when the vehicle is running ie 13 plus volts. Low is good for dedicated battery. We also now have small battery packs you can use in your rig that will run the fridge for 8 hrs at a time and can be used as a pass though or in conjunction with a vehicle battery.

Thanks! I’m on your site now. Do you have a link for the battery packs? I don’t see them.
 
Joined
Oct 14, 2009
Messages
80
Location
Hoquiam, Wa
Thanks. I may need the battery pack. It won’t run on medium either. It shows 12.5 v until the fridge kicks on then it drops to 9.5 for a few seconds, then F1 code. It runs on low but the battery shows 10.2 v on eco. I’ve only had this battery on for a few days but it’s worked flawlessly. Could it be that I need a battery pack?
 
Joined
Apr 3, 2008
Messages
141
Location
Grants Pass Or.
The little battery has done an awesome job. Ran for 8hrs and here is the app readout with the compressor running.

1593212129884.png
 
Joined
Feb 18, 2021
Messages
37
Location
Siegelbach, Germany
Yes they are
Once I am closer to coming back to the US, I will be contacting you for one. I’m currently stationed in Germany but will be coming back end of June. Plan to buy my vehicle in Baltimore and take my time to drive down to Arkansas for my next duty station. Could I have it shipped to a hotel? Thank you
 

Users who are viewing this thread

Top Bottom