Colors of and location of trim clips of passenger rear interior panel

Joined
Dec 22, 2007
Messages
388
Location
Fort Collins, CO
Does anyone have a picture of the original color of the clips and location of the clips that hold on the rear passenger panel? I got this image from Whole Hog "assuming" they were the correct clips in the correct location. After conferring with a dealer at least 1 of clips doesn't match with their parts location. So now I can't trust that the Whole Hog diagram is correct. I used all the same color clips as the Whole Hog diagram and the clips don't hold the rear panel on.

The FSM doesn't show the colors of clips or locations.
Trim clips.png
LAND_CRUISER___64_51___INSIDE_TRIM_BOARD.jpg
 
Last edited:
Joined
Jul 17, 2018
Messages
1,790
Location
LUGOFF, SC
I bought a Toyota trim clip kit at autozone.
I used the white ones in the kit to replace the broken/missing clips on the panel.
 
Joined
Dec 22, 2007
Messages
388
Location
Fort Collins, CO
Joined
Jul 17, 2018
Messages
1,790
Location
LUGOFF, SC
no, those aren't it. they look just like the factory ones. A multi disk tree that snaps into the panel groove and a cone that snaps into the hole.
And no, the panel doesn't vibrate, either that or there are enough other things buzzing that I can't tell if the panel is...:hillbilly:
1660252038800.png


Amazon product
 
Joined
Dec 10, 2007
Messages
8,812
Been discussed before:


FWIW I just pulled the left cargo panel from a US spec 1997 FZJ80 yesterday, all the clips were dark red except one white clip located at the top front closest to the rear door. There was one brown "clip" or plastic stud IIRC that was integral to the panel itself located near the rear of the wheel hump. Will be pulling the right side soon.
 
Joined
Dec 22, 2007
Messages
388
Location
Fort Collins, CO
Been discussed before:


FWIW I just pulled the left cargo panel from a US spec 1997 FZJ80 yesterday, all the clips were dark red except one white clip located at the top front closest to the rear door. There was one brown "clip" or plastic stud IIRC that was integral to the panel itself located near the rear of the wheel hump. Will be pulling the right side soon.
What you wrote is exactly the issue. The panel does not come from the factory with all reds clips. There are 3 colors in specific locations as you mentioned. I'm looking for a picture with the proper color clips in the proper location. I don't care about the cost of the proper clip, I'll buy OEM to make it fit properly.

The link you posted is all about aftermarket clips and don't tell me the correct location and color of the OEM clips.
 
Joined
Dec 10, 2007
Messages
8,812
Read down to post #4 in the link above

Here are the part numbers listed in that post:

90467-10161 (2) WHITE
67771-12050 (28) RED
67771-32060 (2) BROWN


Looks like from the photo you posted is that the locations of the different color clips on the right side is similar to the left ie: all red except one white, maybe a brown one in there somewhere.

If you can wait a day, weather pending, and I'll have the other panel off and can post up a photo of what I find. Been raining the last couple of days so haven't been able to get back to it.

If you wanted to get a jump on it you could order all the clips as listed in the older thread, then you'll have them ready once the placement can be confirmed.
 
Last edited:
Joined
Dec 22, 2007
Messages
388
Location
Fort Collins, CO
Been discussed before:


FWIW I just pulled the left cargo panel from a US spec 1997 FZJ80 yesterday, all the clips were dark red except one white clip located at the top front closest to the rear door. There was one brown "clip" or plastic stud IIRC that was integral to the panel itself located near the rear of the wheel hump. Will be pulling the right side soon.

Looks like from the photo you posted is that the right side is similar to the left ie: all red except one white, maybe a brown one in there somewhere.

If you can wait a day, weather pending, and I'll have the other panel off and can post up a photo of what I find. Been raining the last couple of days so haven't been able to get back to it.

If you wanted to get a jump on it you could order all the clips as listed in the older thread, then you'll have them ready once the placement can be confirmed.

From the linked thread:

90467-10161 (2) WHITE
67771-12050 (28) RED
67771-32060 (2) BROWN
I have all the same color clips as the photo I posted and the clips don't hold. I don't think the proper color clips are in the proper location based on that photo.

That would great if you would be willing to take the trouble to post up a pic of your right side panel. Thanks.
 
Joined
Dec 10, 2007
Messages
8,812
I will get some photos once it stops raining and I get back into it in the next day or two.
 

Broski

I love Wheelin my 80
SILVER Star
Joined
Dec 3, 2015
Messages
4,333
Location
Morro Bay, At the edge of the Pacific ocean
My 94 had all red clips, some were damaged and I replaced them with OEM red clips and they all hold as intended.
1660411489543.png
 
Joined
Dec 22, 2007
Messages
388
Location
Fort Collins, CO
no, those aren't it. they look just like the factory ones. A multi disk tree that snaps into the panel groove and a cone that snaps into the hole.
And no, the panel doesn't vibrate, either that or there are enough other things buzzing that I can't tell if the panel is...:hillbilly:
View attachment 3084225

Amazon product

I got clips from the Amazon link you provided. They are a pretty loose sliding into the slots in the rear panel, but seem to hold the panel pretty snug with no rattles. Good call. Thanks.
 
Joined
Dec 10, 2007
Messages
8,812
FWIW I recently purchased a bag of each three OEM Toyota clips, Red, White, Brown. (photo to follow)

The three different color clips (Red, White, and Brown) are all slightly different from one another mostly in the shape and size of the tip that pushes into the hole in the body. My assumption is that's by design for a tight fit.

For the left hand side cargo panel it's one White in the upper forward corner, one Brown in the lower middle (in the curve), all the rest were Red. With work and rain almost every day haven't had a chance to pull the right side panel yet.
 

Users who are viewing this thread

Top Bottom