Code 28 - 02 sensor (1 Viewer)

Joined
Sep 20, 2003
Messages
155
Hello Fellow Cruiser Freaks!

After the "check engine" light came on yesterday, I retrieved a diagnostic code of No. 28, which is the "post catalytic converter system" per the Haynes Manual. The manual said to check the post (after) cat converter oxygen sensor but I didn't think the 94 models had post cat 02 sensors and I didn't see one either? I did locate the main 02 sensor and 02 sensor heater electrical connections. Any suggestions on fixing this diagnostic code? Thanks.
 

cruiserdan

SupportingVendor Emeritus
Moderator
Joined
Mar 27, 2003
Messages
24,498
Location
Land Cruiser Heritage Museum broom closet
Welcome Douglas,

First off, your manual is not quite up to speed, so it is not gospel. You would be best served by obtaining a Factory Service Manual (FSM).Your 94 has 2 oxygen sensors mounted in the head pipes just in front of the cats. One of them is most likely bad. Codes 21 and 28 indicate failure in these sensors. I recommend that you change both sensors. The part number required is 89465-60110. This supplies you with both sensors and the gaskets required for installation.
1993 and '94 models did have a service campaign to replace the sensors under warranty. If your vehicle has not had this campaign performed, your local dealer can do it for you at no charge. I would be happy to check for you to see if the repair has been done already. You can PM (private message) your VIN to me and I will check Toyota's records to see if it has been done.
You could post your vin publicly but it would be best left private.

Cheers, and glad to have you aboard, Dan. :cheers:

Oh, since junk is off-line :flipoff2: :flipoff2: :flipoff2: :beer:
 
Joined
Jul 14, 2003
Messages
2,195
Location
Hopewell NJ 08525
well
It looks like today is the O2 check eng light day ::)

I was nice enough to have the light come on as I was out cruising in the new to me 96 fzj80 with just over 95k on the odo.
Well out came the Snap On scanner to test the system :D
I had a code #P0420 catalyst efficiency low bank ?
Well looks like the dealer I got it from is going to have kittens when I bring it back as it must pass NJ inspection and ck eng light on is a instant smog fail :p plus I told them that the parking brake needs to be fixed also when i bought it but they didnt fix it (bell crank stuck so shoes are shot ) they thought by just adjusting the pass side way up I wouldnt notice :doh:
. Well boys I have digital camera and I will take pixs and a little video too (cool ass camera does it all )
They are going to wish I never set foot there :D
The best part is if they try to take it through after clearing the codes they will be beat as the OBDII will show the codes were just cleared so NJ ispection will not pass it anyhow . The dealer is right across the street from the station (less then 50 yards ) :whoops:
Sometimes you got to love big brother when you aren't the ones getting it in the shorts from them :flipoff2:
 

landtank

Supporting Vendor
SILVER Star
Joined
Mar 27, 2003
Messages
20,213
Location
Groveland MA
Website
landtankproducts.com
At 117K i had the P0136. This was just after a Borla exhaust install. SO I did a complete tune up and disconnected the battery so as to reset the code as well as the fuel maps. Well almost a month and no code. Life is good :D.


Probably will get it tomorrow now :rolleyes:
 
Joined
Mar 13, 2003
Messages
5,787
Location
North Front Range, CO
landtank, I had my CE light on on my Previa. I reset the computer. Months later it came on again. Reset it again. Then when I had it sold the light came on and stayed on. It was O2 sensor. I got a new O2 sensor and it was like I added a turbo. I woundered why this Previa was a dog. My other one had more power. Now I know why.
If you have loss of power, it could be the O2 sensor.
 
Joined
Sep 20, 2003
Messages
155
CDan, I'm lucky enough to have all records and history of my 94 (I am the 3rd owner and purchased 6 months ago). I found a receipt from 1997 with the 02 recall work done. I'll check my local dealer for the 02 replacement kit. I assume I will need to purchase a special socket also?? Thanks for your help!
 
Joined
Dec 23, 2006
Messages
1,369
Location
Covington, GA
Dan,

I know this is an old thread, so I hope you see this post. I have a '94 LC and just got a code 28. Could you tell me more about this service campaign to replace these O2 sensors. Will my local dealership know what I am talking about if I ask for this work to be done under warranty? I don't have my VIN right now the truck is not at home right now.

I have already special ordered this part, I think the kit (for one sensor) was over$175.

Thanks for your help

Sidney
 

Brentbba

Former Golfer
SILVER Star
Joined
Mar 27, 2003
Messages
10,548
Location
OC, CA
Rats! Looks like my recall was completed back in '97. Looks like I'll be buying new sensors.

Adam

Call Cdan for the parts! You'll save coin and I'll give you a 99.9999999% probability he's got them in stock! They are easy to install. Being in Colorado, you may want to hit the nuts with something like PB Blaster a day or two in advance to loosen any rust first.

It's no wonder he get's grumpy :flipoff2: at inventory time. American Toyota has got to have one warehouse dedicated to cruiser parts alone! :cheers:
 

Brentbba

Former Golfer
SILVER Star
Joined
Mar 27, 2003
Messages
10,548
Location
OC, CA
Post was from 2010. Check discontinued parts thread. I think the OEM O2 sensors are goners as I think I purchased one of the last sets that was in the states at that time.
 
Last edited:

Users who are viewing this thread

Top Bottom