Code 25, idles a little low, Missfire at 2200rpm

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Jan 11, 2012
San Diego
OK, I have been searching this all afternoon and come up with a few things to start looking at but thought I would throw this out there since I haven't seen this particular problem posted. Truck is a 93 w/ ABS, 235,000 miles.

Had 2 times over the last few days where the truck died when I came off the throttle. Both were driving up a hill and stopping at a gate.

Noticed that the idle seemed a little low at around 500rpm.

Today I got a CEL code 25. It was on for a bit them went back off.

While going over the truck and looking and listening. I noticed something weird. When I have the truck in the driveway in park, if I slowly rev the engine I am getting a misfire at 2200rpm. Once I hit 2200, it drops for a second to 1400 then back to 2200. It bounces like that a few times before the RPMs go beyond 2200.

I was initially thinking O2 sensors and maybe the PAIR Valve but the misfire at the specific RMP has me thinking otherwise. Troubleshooting in the FSM is showing the following are common suspect areas for the misfire and engine stall after accel pedal release.

EGR System
Volume Air Flow (VAF) curcuit

Only thing that cross references to the Code 25 is the VAF.

Going to test the VAF and see what it does.

Any other ideas?

Well it looks like its the VAF. I tested resistance between pins 5 and 6 and got 4800 ohms closed and 4000 open. That's not good. I guess I will order one and see if that does the trick.

By the way I have done the following work recently.
Replace the raditor due to a crack.
Changed fluids
Replaced the TPS.
Last edited:
OK, It does not appear to be the VAF.
It turns out that the pins it tells you to measure resistance on in the FSM are wrong. :mad:
You need to measure between Pin 5 and 6. The picture shows pin 6 and 7. Thankfully I have the EWD and was able to figure out the right pins and all are pinning out OK. Glad that I don't have the buy a $700 sensor and figure out I didn't need it.
Any ideas on what to look at next?
OK, Figured it out. It looks like the hose that goes into the intake manifold had a loose clamp on it. Not sure how it got loose but once I tightened it up we are back to normal.
OK, so the saga continues...
Got the CEL again with the low idle. Now the idle is really low like 200-300 rpm. Once I give it some gas its fine. Sputter at 2200 rpm is gone though, so that was probably the loose hose. I let the truck idle for 10 minutes then took it for a drive around town to let the computer reset and still the same low idle and the CEL came on again but this time I am getting 25 and 26.
I will do some searching as well.
O2 sensors age is unknown. I have had the truck for about 6 months and they were on there when I got it. I tried unplugging them and the slow idle persisted. Cleared the codes with them unplugged and same thing. Plugged them back in and cleared the codes, same thing.
I am thinking that I may have done something to the VAF when I tested it. It seems like the idle is worse after I did that.
I checked the throttle cable and the jacket looks like crap but the cable slides pretty easily inside.
New TPS a few months ago so I don't think it could be that.
Tried moving around the wiring harness around the ERG with no changes in idle.
Didnt see any other loose hoses.
Your symptom sounds like mine when I had a electrical connector with a bad seal and water would get in the connector and short out something. Read post.

Unplug all of your electrical connectors and see if water or corrosion has shorted it.

<<<Checked all the sensors and they were good.
Stated checking all the plugs. I put dielectric grease in all my plug so I wont have a problem.
Blew air in all the electrical connectors/plugs and found one that is leaking where the wire goes into it. Water blew out when blew it out.
It was the plug in next to the alt where the wires "Y" into to the alt, and to the intake plenum. The plug is the one that is mounted to a bracket.

Wonder if I can get new rubber that goes in the plug or do I have to use RV sealant.

I have hosed my motor of for years and other than the dist getting wet, I have not had a problem.
I put a plug in the vent hole this time and it worked.

The question still is. What part in the motor keeps it from rev'ing over 2200 rpm?>>>
I had the same issue a month ago, replaced 02's.... runs like new.
OK, I will order the O2 sensors for CDan today. In the mean time I will go through the electrical connectors and blow out and dielectric grease all of them that I can get to. I really dont think its a water thing since it has been dry here for the last 2 months.
Just so we are clear, the 2200rpm thing went away once I tightened the intake hose where it goes into the intake. Now its just the really low idle.
Correct, Codes 25 and occasionally 26.
Did you ever figure this out?? I have 25 now... I had 25 & 26 - but for me 26 turned out to be the throttle position sensor.. It needed to be adjusted.. When the throttle closed the TPS would still be slightly open.. so it would never indicate that the throttle was closed.

Users who are viewing this thread

Top Bottom