Clarification on Testing the Distributor for Codes P0340 and P0335

Joined
Sep 11, 2021
Messages
4
Location
lytle tx
Hi guys this is my first time posting, learning a lot from this forum. I have a 1997 LX450 with 243k miles that I purchased in June. Has been running great for a few months then has recently shut off, without hesitation randomly..then cranking but won’t start. Giving me P0335 Crankshaft Pos Sensor code along with P0340Camshaft Position Sensor code. I have read others have had issues with the connection on top of the distributor which is what both sensors have in common. The repair manual states to check resistance between terminals 2,3,and 4 to diagnose the P0340 Camshaft sensor code BUT FIRST SAYS DISCONNECT CAMSHAFT POSITION SENSOR CONNECTOR. I know these are built into the distributor so does that mean to just disconnect the DISTRIBUTOR CONNECTOR? I see no other connections. Any help would be greatly appreciated as I am trying to figure out the issue.
Testing as is with just the distributor connector unplugged I read around 540 ohms between terminals 2-3, 265 ohms between 2-4 and 3-4 which leads me to believe that I may have to replace the distributor assembly as readings from 2-3 should be between 185-275 ohms Cold.

ADB4F8F4-F8E0-470A-A69A-525694E0D2D6.jpeg


83297C27-DC9F-4B00-A425-49D77C0E14F3.jpeg
 
Joined
Sep 11, 2021
Messages
4
Location
lytle tx
To answer my own questions. Yes the distributor assembly was the problem. Replaced it with a used OEM one from cruiserparts and now running great. No more issues. Cleared the CEL codes and they haven’t come back. Been driving it for about a week now. Anyway hope this is helpful for anyone haven’t the P0335 and P0340 codes.
 
Joined
Dec 10, 2007
Messages
7,836
The distributor shown above appears to be an aftermarket part, is that correct? Brand name, part number??
 
Joined
Sep 11, 2021
Messages
4
Location
lytle tx
The distributor shown above appears to be an aftermarket part, is that correct? Brand name, part number??
Yessir it was an aftermarket part. Was already leaking internally. Went with an OEM 1fzfe distributor that was used but tested good from cruiserparts.net. (19100-66020) is the OEM part
 

Users who are viewing this thread

Top Bottom