CCOT Clutch upgrade kit struggles. (1 Viewer)

projectTuRD

SILVER Star
Joined
Aug 9, 2016
Messages
385
Location
California
I’ve got to be missing something. I’m pretty bad with this stuff so it’s got to be me.
There’s no way this is supposed to look like this?
The soft hose doesn’t fit the bracket and the hard pipe doesn’t end up anywhere near there anyway.
What gives?

288645B2-2902-413E-8422-1159435B04EE.jpeg
 

projectTuRD

SILVER Star
Joined
Aug 9, 2016
Messages
385
Location
California
It looks to me like the hard line has been replaced too. Both should probably mate up with the tab on the firewall rib.
The hard and soft lines come with the kit along with a master and slave cylinder.
I have to be wrong somewhere, there’s no way such a major player could ‘engineer’ something that makes so little sense?
 

73FJ40

After another night of rust removal!
SILVER Star
Joined
Dec 28, 2006
Messages
1,890
Location
Western Massachusetts
@projectTuRD

As @B y r o n pointed out, the original routing of the hard line went from the master cylinder to the tab with with the whole in it:

1656984446550.jpeg


The hard line was supported by the tab, and the female end of the flex hose was locked in place with a clip.

This is on a '73 model, but I suspect your rig started with something similar.

Does CCOT expect you to bend the hard line to the tab, or is the hard line just supposed to hang in mid air, with the flex hose tugging on it?

:meh:

1656984838198.jpeg
 

projectTuRD

SILVER Star
Joined
Aug 9, 2016
Messages
385
Location
California
@projectTuRD

As @B y r o n pointed out, the original routing of the hard line went from the master cylinder to the tab with with the whole in it:

View attachment 3050281

The hard line was supported by the tab, and the female end of the flex hose was locked in place with a clip.

This is on a '73 model, but I suspect your rig started with something similar.

Does CCOT expect you to bend the hard line to the tab, or is the hard line just supposed to hang in mid air, with the flex hose tugging on it?

:meh:

View attachment 3050288
@projectTuRD

As @B y r o n pointed out, the original routing of the hard line went from the master cylinder to the tab with with the whole in it:

View attachment 3050281

The hard line was supported by the tab, and the female end of the flex hose was locked in place with a clip.

This is on a '73 model, but I suspect your rig started with something similar.

Does CCOT expect you to bend the hard line to the tab, or is the hard line just supposed to hang in mid air, with the flex hose tugging on it?

:meh:

View attachment 3050288
I know how it was run, I took mine out 😉
I wish I could find an original master and use my old lines.
 

73FJ40

After another night of rust removal!
SILVER Star
Joined
Dec 28, 2006
Messages
1,890
Location
Western Massachusetts
My mistake for the confusion regarding your OP.

If you knew what it looked like since you took it out, looks like you should have consulted with @Pighead before spending big bucks with CCOT.
 

projectTuRD

SILVER Star
Joined
Aug 9, 2016
Messages
385
Location
California
My mistake for the confusion regarding your OP.

If you knew what it looked like since you took it out, looks like you should have consulted with @Pighead before spending big bucks with CCOT.
No mistake, I didn’t clarify very well. Even worse, I bought the same master, slave and soft line a year ago off amazon and forgot about the slave. I threw the new soft line into the old slave and boogered it up. Then I bought the ccot kit recently not realizing it’s all the same stuff but with a useless hard line. 🤦🏼‍♂️🤣
 

Users who are viewing this thread

Top Bottom