carb problems (1 Viewer)

Joined
Feb 19, 2004
Messages
390
Location
ventura,ca
 
 
 
Hi all, my carb is acting funny, when the engine is cold it holds idle o.k. but has a very rough idle, once the engine is warmed up the truck idles very high (I do not have a rpm gauge on the truck to know the rpm speed is) and is a smooth idle. I recentaly had a rebuilt motor installed (22r) and it runs and sound fine otherwise, no knocking, pinging, or valve noise. I have tried spraying some carb cleaner into the carb and run some fuel cleaner into the gas tank both with no results or improvements. The exhaust is not smoky but does throw out some black like stuff (carbon?). Any help on what the problem might be, and thanks in advance.
Cliff
PS it is the original carb that came with the truck when I bought it new in 85'.
 
Joined
Oct 14, 2004
Messages
3,570
Location
Virginia Beach, VA
 
 
 
What is your choke doing?? Is the plate open or closed when warm or cold. Sounds like a choke problem to me but could also be a temp sending unit or wiring to the choke. If the choke plate is open when warm, adjust the idle down to 850 or so, and see what happens when cold. IIRC there is a choke adjustment as well, it doesn't sound serious but let us know.
Good luck,
Dan
 
Joined
Feb 19, 2004
Messages
390
Location
ventura,ca
 
 
 
Thanks Kliers, I'll start with messing with the choke this weekend. I took the truck back to the guy who installed the engine to see if he could help with the problem and he tried adjusting some screws under the passenger side of the carb and could not get any change to the problem. Any ballpark amounts for having someone rebuilding the carb if all else fails?

Thanks, Cliff
 
Joined
Oct 14, 2004
Messages
3,570
Location
Virginia Beach, VA
 
 
 
Those carbs are pretty easy and cheap to rebuild, relatively simple design and not too many small uselss pieces.
Let us know what happens with the choke.
Good luck,
Dan
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom