Brakes....check vacuum

Joined
Sep 20, 2019
Messages
36
Location
ST.Louis MO
A few months back I replaced the brake calipers, rotors, hoses, pads, etc. flushed the fluid, bled the system and the brakes were OK. Recently I lost the power brake booster. Turns out it was a blocked vacuum line from the intake. Cleared that out, and holy hell.....the brakes work great! It may be worth a few minutes to clear out the vacuum port for your brakes.
 
Last edited:
Joined
Feb 4, 2021
Messages
6
Location
Beaumont, TX
A few months back I replaced the brake calipers, rotors, hoses, pads, etc. flushed the fluid, bled the system and the brakes were OK. Recently I lost the power brake booster. Turns out it was a clocked vacuum line from the intake. Cleared that out, and holy hell.....the brakes work great! It may be worth a few minutes to clear out the vacuum port for your brakes.
So what was the “symptom” of clogged vacuum line? All of a sudden my brakes have no power at low speed wondering if that may be my problem
 
Joined
Sep 20, 2019
Messages
36
Location
ST.Louis MO
So what was the “symptom” of clogged vacuum line? All of a sudden my brakes have no power at low speed wondering if that may be my problem
Mine were intermittent especially at low speeds. The brakes work, but there was no power boost. At a stop, or very low speeds, after extended light braking the pedal would sometimes push back on my foot. There is also a hose, check valve, and grommet. My grommet was dry and cracked so I replaced that as well, but it did not fix the problem at first.
 

Users who are viewing this thread

Top Bottom