blue smoke after head has been replaced

Joined
Apr 8, 2021
Messages
5
Location
Melbourne
Hey guys Ive just had my head,cams and valves all replaced about 2 weeks ago now and when I start it up it blows a bit of blue smoke out and does a bit when I take off should I be worried as I’ve spent a lot on a new head.
 

TYM4FUN

SILVER Star
Joined
Aug 16, 2012
Messages
2,969
Location
USA
Hey guys Ive just had my head,cams and valves all replaced about 2 weeks ago now and when I start it up it blows a bit of blue smoke out and does a bit when I take off should I be worried as I’ve spent a lot on a new head.
New OEM?

If not, Maybeeeee, on the very 1st start, after that issues... Did the valve guide seals get replaced?

Next on list is making sure your PCV is working, then diagnose piston rings.
 

TYM4FUN

SILVER Star
Joined
Aug 16, 2012
Messages
2,969
Location
USA
Also, download a copy of the FSM, as it will have everything you need to pinpoint most issues.
 
Joined
Dec 10, 2007
Messages
8,983
Engine will produce smoke on the first start up depending on how much oil/solvent was left in the cylinders or maybe the intake plenum, but that should all be done in a few minutes max.

Was the engine blowing smoke before the head job?
Why was the head pulled: increased oil usage, blown head gasket?
What tests were done before the head was taken off (compression/leak-down)?
Did the shop/machinist check the valve stem guides for wear?
Did they check the bores of the cylinders for concentricity?
Did you do an Engine Oil analysis before the head was pulled to check for wear metal levels or contamination (water/coolant)??
What parts were used, new OEM valve stem seals?
 

Users who are viewing this thread

Top Bottom