Any reason CEL would come on after...

Discussion in '80-Series Tech' started by drnls, Nov 12, 2005.

  1. drnls

    drnls

    Messages:
    237
    Likes Received:
    17
    Joined:
    Oct 7, 2004
    Location:
    S. Texas
    Any reason CEL would come on after... Found the problem

    Decided to change transmission, diffs and transfer case fluids today. Just drained the trans and re-filled with 6 quarts. Drained the other three and re-filled. While I was down there decided to change out speedo gear I've had for two years. Replaced w/ no problems. Warmed up engine, went thru the gears several times - trans fluid level - a little above normal. Went to Lowe's and on the way home CEL light came on. Any ideas? Does the computer have to be reset when changing speedo gears? I currently have 134,000 mi. I'll try and run it by Auto Zone tomorrow. Nelson

    Thanks to those that answered. There is a little "pin/key" that came out with the old gear - didn't install with the new. Should have paid more attention. Nelson
     
    Last edited: Nov 13, 2005
  2. NorCalDoug

    NorCalDoug problems solved daily...

    Messages:
    6,293
    Likes Received:
    118
    Joined:
    Oct 27, 2003
    Location:
    uhhhh...duh...Northern CA
    My trans drain/refill works out to 4 quarts. I wouldn't think too much tranny fluid would spark a MIL coming on. Never heard of the speedo gear doing that either.
     
  3. TX_TLC

    TX_TLC

    Messages:
    1,480
    Likes Received:
    9
    Joined:
    Apr 29, 2003
    Location:
    Texas
    Pull the code or have it pulled at Autozone for free...this will tell you.


    My bet is on..."coinsidence".
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.