Anti inversion shackles hitting the leafs.

Joined
Apr 3, 2020
Messages
39
Location
Holstebro, Denmark
I have just installed TerrainTamer parabolic Leafs on my 75 series.
With them came anti inversion shackles.
My problem is now that the front shackles hit the leafs all the time.. well not the leafs but that little bracket thing. (Please see attached pictures.)

Any idea what is going on?

Did I get the wrong shackles? Did I mount them wrong? And since I am traveling right now.... Can I just cut of the part of the shackles that are hitting and turn then into normal shackles?

20220804_091445.jpg


20220804_091442~2.jpg
 
Last edited:
Joined
Apr 3, 2020
Messages
39
Location
Holstebro, Denmark
So it turns out it is a design flaw on the leafs. TerrainTamer got back to me and said I should just remove the bolt and bend the clips over the top leaf. (Please see attached picture)
They said they will move the clip position in the next product batch.

Since the clip is just boltet onto the leaf with a countersunk 8mm bolt. I was thinking if I could just drill a new hole about 5 cm further from the shackles, pry the 2 Leafs apart, move the countersunk bolt from it's original position to the new hole and then just mount the clip in a new position.

I know this would weaken the leaf a little but there is already holes in it for the clip bolt and also one larger to hold the rubber in place.between the 2 Leafs.
So does one more whole really matter.

IMG_0031.jpg
 
Joined
Mar 10, 2019
Messages
730
Location
melbourne, Oz
Gotta say, that kind of sucks they sold you that as a kit, you paid top dollar plus shipping, went half way cross the world and it hits the shackle. Doh.
TT is normally pretty good, and they charge a bit more for it. They should do better, makes sure it works first, then take money. They make heaps of money.
I guess parabolics are still in early days.
 

Users who are viewing this thread

Top Bottom