1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Antenna help

Discussion in '80-Series Tech' started by Ivan, Dec 25, 2003.

  1. Ivan

    Ivan

    Messages:
    42
    Likes Received:
    0
    Joined:
    Dec 11, 2003
    so the PO's kids broke off the old mast :(
    just got the new part (mast with shim only) and tried to install it.
    it was a pain to unscrew the old one, but i got the new one on.
    only problem is it doesn't retract flush. it still sticks up about 3"
    there is a red plastic stop piece on the bottom of the new mast that keeps the shim with the black rubber head from sliding off the mast. was i supposed to remove the red plastic bit? any advice as to where i went wrong...
     
  2. 97cruiser

    97cruiser

    Messages:
    317
    Likes Received:
    0
    Joined:
    Aug 7, 2003
    Location:
    Lewiton, Idaho
    Have you tried using the up and down antenna controls located on the dash?
     
  3. Ivan

    Ivan

    Messages:
    42
    Likes Received:
    0
    Joined:
    Dec 11, 2003
    yeah, it's a '93, so that's the only way it goes up and down. (don't think it's connected to the radio on these) goes up and down fine, but with the "clink, clink, clink, clink" sound.

    it seems to go up the entire way up but on the way down, it stops with about 3" still sticking up.

    seems like the motor, nylon cord, cord nut, etc., are fine.

    any idea what i may have done wrong?
     
  4. Hwn built

    Hwn built

    Messages:
    105
    Likes Received:
    0
    Joined:
    Sep 17, 2003
    It's junk, just send it to me and buy a new one... ;) :D :flipoff2:
     
  5. Ivan

    Ivan

    Messages:
    42
    Likes Received:
    0
    Joined:
    Dec 11, 2003
    ;) part seems ok...

    any ideas? i'm stumping the ol' noggin on this one.

    thanks in advance
     
  6. Lars

    Lars

    Messages:
    658
    Likes Received:
    1
    Joined:
    Apr 17, 2003
    My newly purchased 93 is the same way. Antenna only retracts to about 3" from flush. I can tell the previous owner has tampered with it judging by the plier "teeth" marks at the base of the mast.


    I'm too am interested in a fix.
     
  7. Ivan

    Ivan

    Messages:
    42
    Likes Received:
    0
    Joined:
    Dec 11, 2003
    lars-

    does yours make the "cank, clank, clank" noise?

    is this normal, guys?

    seems like something is wrong and it should be retracting flush.
     
  8. landtank

    landtank SILVER Star

    Messages:
    18,988
    Likes Received:
    1,127
    Joined:
    Mar 27, 2003
    Location:
    Groveland MA
    I only get that noise when I max out in one of the directions. Seems like you might have a damaged shaft.
     
data-matched-content-rows-num="2,1" data-matched-content-columns-num="1,4" data-matched-content-ui-type="image_stacked" data-ad-format="autorelaxed">