Another idle problem-long

Joined
Jun 25, 2004
Messages
189
Location
Pa.
I got my carb back from Jim C. and things ran great. I was hearing some exhaust leak,so I thought I'd put a new gasket on the header.It was after I had the new gasket installed,did I realize I should use two gaskets.Well,on the way home,it blew out.It's not bad,but enough to know it's leaking. I checked the vacuum and it's running around 11.I also noticed the carb is leaking around the primary throttle shaft below the sight glass.It only leaks when you work the linkage and not running.I ordered the two piece header from sor and two Felpro gaskets.My question is,will the gasket leak mess up the idle that much?And why would the carb be leaking? I can get it to run,but I have to keep the choke out.
I'm not messing with the adjustments until I get the new header on. Thanks for any help!!
I forgot to say it's a '74 40 with the F motor.
 
Last edited:
Joined
Feb 17, 2005
Messages
50
Location
Socorro, NM
I wouldn't worry too much about the leak when not running. The accelerator pump is squirting gas in with each actuation and the gas is collecting on the throttle plate, then oozing out.

Yes, the gasket is allowing a vacuum leak which is why it only runs when richened.

What I don't understand, is why it blew the gasket out?
 
Joined
Jun 25, 2004
Messages
189
Location
Pa.
It has a one piece header,and I had a guy replace the gasket.I was going to do it,but the nuts were really rusted and I thought if something broke,I wasn't going to be the one to do it!!!The fit is not very good. When I got it home,the nuts were not tight at all.I could turn them over half a turn.That's why I ordered the two piece header,and now I'll do it myself.Thanks for the info!!!
 
Top Bottom