alternator question

Joined
Feb 19, 2009
Messages
2
88 landcruiser alternator **** the bed. Replaced with new alternator, note; that there was high voltage. voltage meter in dash was peged out, but all and all it Worked great for about 2 weeks. Then one day i turn the truck off go into work and come out after work and the battery is dead due to alternater not charging the batt. After further inspection found loose wire on the back of the alternator. tightend down and now the alt is giving off low voltage. I checked all the leads everything is tight and has good connections. I hear some talk about a voltage regulator was thinking that could be the culprit??

i'm not to worried about it but i was wondering if anybody has had this kind of issue before. I work on helocopters not trucks!!!! Thats my excuse....
 
Joined
Oct 31, 2003
Messages
5,025
Location
Meridian,TEXAS
Check out the battery first........ It may have suffered trauma and can't maintain....

The regulator is internal, have the alternator checked out.......
 

REKCUT

SILVER Star
 
Joined
Jan 5, 2005
Messages
4,180
Location
Rogersville, Mo.
Have alt tested. I bought a new on from Orielly Autoparts and installed it. It turned out to be bad. Went back to the store and got another and had it tested at the store before I left. It also was bad along with the only other one they had on hand. Had to order in another batch before I got a good one. Lesson learned is always have them test it before you leave so you dont have to R&R more than once.
 
Top Bottom