After 4 years, I drove my pig today......??

Joined
Jul 13, 2003
Messages
786
Location
Folsom, CA
Well, after sitting in my concrete paved side yard for the past 4 years, I actually drove my 75 pig today for a grand distance of 10'. Yes that is correct, a total of 10' before I had to shut it down. Not because of a drive train issue, but for the steering :mad: I have no idea what caused this, but my scout steering box took on a mind of its own. When I turned the wheel to the right, past center, the steering box and pump would sharply turn the wheels the rest of the way to the stops, without my touching the steering wheel. To turn it back to the left, I had to turn the engine off and turn it manually. With the engine running, no matter how hard I pulled, I could't get the wheels to turn left. Quite bazaar :eek: Now, I don't know if the box is bad or the pump. And, yes, I pumped the steering fully in both directions to bleed the lines. When I left it tonight, the pump was spewing fuild, after I had turned the engine off. Darn, I was really looking forward to driving it further than 10' tomorrow :crybaby:
 
Joined
Mar 5, 2005
Messages
101
Location
Pagosa Springs, CO.
Sounds like a problem with the box to me. maybe in it's orbital valve, thingee-muh-bopper... If it managed to turn all by itself, then the pump must be working. It is likely spewing fluid if it's return or supply is plugged in the box side (I'm leaning towards the return valve, which could cause the self-steering you described)...

Just some ideas, nothing concrete. Good luck!
 
Joined
Jul 13, 2003
Messages
786
Location
Folsom, CA
Still have the problem with the power steering. Putting a different pump in it tonight to see if that helps. Swapped out the box, which did not solve the problem.
 
Top Bottom