Accelerator Linkage brain fart 78 FJ40 (1 Viewer)

Joined
May 4, 2010
Messages
2
I removed the carb for a head replacement but time got away from me and after 3 months and a move, am having troubles getting the accelerator linkage hooked up. I have one end of the the longer accelerator rod in the bracket attached to the firewall and the other end connected to the shorter acc rod but at this end of the longer acc rod there is also a post with a cotter pin and washer that I can find it's home. Without this hooked up the entire linkage just flops around. Any help would be appreciated..
FJ40 Throttle linkage.gif

IMG_5867.jpg

IMG_5868.jpg

Thanks much
FJ40 Throttle linkage.gif
IMG_5867.jpg
IMG_5868.jpg
 

Poser

Oh...Durka Durka Durka.
s-Moderator
Supporting Vendor
Joined
Oct 1, 2003
Messages
20,456
Location
MN
Welcome.


Where is your pivot bracket? #55 in your drawing from Marv.

Mounts to the studs on the carburetor base.


:meh:
 
Joined
May 4, 2010
Messages
2
That would probably help and looks like it was lost in the move.

Thanks
 
Joined
Jan 25, 2009
Messages
167
Location
Wisconsin
Is #50 a bushing? I am was working on the same thing tonight and it looks like I am missing a bushing.
 

Poser

Oh...Durka Durka Durka.
s-Moderator
Supporting Vendor
Joined
Oct 1, 2003
Messages
20,456
Location
MN
Is #50 a bushing? I am was working on the same thing tonight and it looks like I am missing a bushing.



Yes it is.

There is also a washer that is on the carb side of that pivot rod after it passes through that bushing that is retained by that spring clip.


:meh:
 

Users who are viewing this thread

Top Bottom