A thermostat is a thermostat is a?

Joined
Oct 4, 2009
Messages
280
Location
Walnut, Ca
Visit site
A search revealed a whole lot of other stuff !!!

In my case all cooling system was recently renewed with all new hoses water pump radiator and 8 blade fan.

Last night I went for a little cruize weather was about 60F, my idiot temp light was really high, I turned around and went home. I popped the hood and the hoses and radiator was really really hot.

So today I pulled the thermostat housing and Im wondering if my thermostat is working or not. I further discovered i probably have 90/10 antifreeze far too green so I will drain and try 60/40.

Is this after market 180f stat ok for my rig, or should I have picked up an oem stat.

I also noticed the upper rubber gasket does not fit properly on the stat but does fit perfectly on inner top housing, is this a proper fitting, could this be contributing to what i believe is a hotter than normal running system.

Im going to pick up a mechanical temp gauge for a piece of mind and avoid a cracked head.

I noticed some guys place food/cooking thermometers into the fins of their radiators, is this effective and what should temps run at while on highway.

Im going to try running without a stat to see what happens in the mean time.
 
Joined
Oct 4, 2009
Messages
280
Location
Walnut, Ca
Visit site
Will any thermostat that fits work, this is an aftermarket one along with rubber gasket from kragens .
128 035.jpg
128 036.jpg
128 039.jpg
 

Gun Runner 5

KI4CMQ
SILVER Star
Joined
Oct 22, 2009
Messages
17,901
Location
Thomasville, GA
Visit site
While I have no opinion on what thermostat to install I can suggest replacing your antifreeze with "Evans Coolant" which is not water based and offers a much larger range of protection.
You can find additional information on this product on the Forum.
.............1978HJ45
 

myquestoyota

SILVER Star
Joined
Mar 1, 2010
Messages
2,562
Location
Western WA
Visit site
doesn't hurt to check

I just mentioned it as a way to troubleshoot, I thought it was a new thermostat, may or may not be the problem.

I prefer to test parts as opposed to changing them until I find what's wrong. Save my $ for the problems.
 
Joined
Oct 4, 2009
Messages
280
Location
Walnut, Ca
Visit site
The thermostat was purchased new, while this was removed it was tested and worked accordingly. Today I ordered a factory oem rubber and paper gasket. The thermostat removal and installation is as easy as pumping gas, so I dont mind it however the siliconing part I do mind a bit.

Does anyone have a good aftermarket stat part #. The dealer wants $50.00 . Also ive seen rock auto has 2 or 3 different styles, do they all perform equally ???

Ill try that evans coolant you suggested hj45 ! thanks

Im going to try a few things today.....run an aftermarket temp gauge, clean the sending unit and attachement adjusting the coolant/antifreeze to different concentration and burbing the system.
 

Users who are viewing this thread

Top Bottom