A/C question.

Joined
Apr 6, 2005
Messages
1,005
Location
Fairview, NC 28730
My a/c clicks off as my revs slow below 1100. I can sit at a light and still feel the cool air blowing as long as I have the revs up with the pedal. When I relese the gas the revs slow tonormal idle and the a/c cuts off and blows not warm but definantley not cold air.

Is this normal?

If I keep the r's up for a period of time like a hwy trip, i can hang meet in the cruiser. When it works it works well. So I don;t think it's a leak or something like that.
 
Joined
Aug 11, 2003
Messages
332
Location
North Florida
Mine was doing the same thing, last fall now it will not engage at all, slow leak. I think you problem may be low coolant level.
 
Joined
Apr 6, 2005
Messages
1,005
Location
Fairview, NC 28730
So my original condenser had a major leak... unusable/unfixable. I replaced it and had the system evacuated of r12 and replace with 134. It did this the moment I left the A/C shop. Should I ask them to add more coolant?
Is there a way I can ceck the coolant level without taking it somewhere?
 
Joined
Sep 29, 2003
Messages
325
Location
Oregon, USA
Their is a ac modulator under the glove box with a little blue knob on it. Use it to lower the idle speed at which the ac kicks on.
 
Joined
Apr 6, 2005
Messages
1,005
Location
Fairview, NC 28730
And THAT my friends is why I love this place!!!!

Little blue knob... ha.

Sweeeet.

Thank you all very much. I hope I can one day repay you for the patience and knowledge.
 
Joined
Apr 6, 2005
Messages
1,005
Location
Fairview, NC 28730
Ok. That knob adjusts when the a/c comes on. Is there something that raises the rpm when the a/c is on. I have set it so it comes on at an idle, however when it comes on it brings the idle rpm to a very slow lope. Hasn't and won't stall, but very rough slow idle. I thought I saw somewhere a 'thing' that brings up the rpm when the a/c is on, but I'm not sure where I saw it. Or is that a function of EFI only?
 
Top Bottom