99 LC Won't Start Engine light on and security light on (1 Viewer)

ranma21

Supporting Vendor
Joined
Apr 18, 2005
Messages
3,323
Location
Houston, TX
Yes I search, I think I have ruled out the bad fuse box like most people experience. Key inserted and turn to ON position, engine light stays on but security light stays blinking. Starter crank strong but no start, so vehicle starts fine before I disconnected the battery to replace starter as preventive maintenance, couldn't think of anything that could have causes the security light not going off by replacing the starter. To make sure the fuse box is not faulty, I also run the positive wire directly to relay hoping it will start with no luck.

Since security light not going off when key inserted into the ignition, looks like there may be faulty part in the immobilizer system. So now I am thinking either the transponder key is bad, ignition coil bad, transponder amplifier bad or ECU bad. Anyone with similar issue?
 

Mauser

Supporting Vendor
Joined
Jun 20, 2018
Messages
1,448
Location
Central New Mexico
What year? I doubt it is the key, but you might try using a spare.

Haha. Just read the title and saw it is a 99
 

ranma21

Supporting Vendor
Joined
Apr 18, 2005
Messages
3,323
Location
Houston, TX
What year? I doubt it is the key, but you might try using a spare.

Haha. Just read the title and saw it is a 99

Now do you know if LX470 and Landcruiser ECU are compatible when it comes to immobilizer part? I have a 99 LX470, the part numbers on the ECU are different. So I put the LC ECU into my 99 LX, plugged in just fine, but security light remain on. Then I swap my 99 LX ECU into the 99 LC, the security light stays on as well with the LX key on top of the barrel. So that tells me that the immobilizer somehow works a bit different.
 

Mauser

Supporting Vendor
Joined
Jun 20, 2018
Messages
1,448
Location
Central New Mexico
Now do you know if LX470 and Landcruiser ECU are compatible when it comes to immobilizer part? I have a 99 LX470, the part numbers on the ECU are different. So I put the LC ECU into my 99 LX, plugged in just fine, but security light remain on. Then I swap my 99 LX ECU into the 99 LC, the security light stays on as well with the LX key on top of the barrel. So that tells me that the immobilizer somehow works a bit different.

The immobiliser is the same. You should be able to swap between the two. Even with the LX key close to the ignition switch it will probably read the chip of the key in the ignition switch.
 

ranma21

Supporting Vendor
Joined
Apr 18, 2005
Messages
3,323
Location
Houston, TX
Thanks for chimming in buddy =) Found the issue!!! The damn ignition key coil is faulty!! Swap the key coil into the LC from my LX,, and security light went off and voila it starts right away. Just so happened without anyone touching it!!!
 

Mauser

Supporting Vendor
Joined
Jun 20, 2018
Messages
1,448
Location
Central New Mexico
Thanks for chimming in buddy =) Found the issue!!! The damn ignition key coil is faulty!! Swap the key coil into the LC from my LX,, and security light went off and voila it starts right away. Just so happened without anyone touching it!!!

Good deal. I was just going to offer to send you some immobilizer parts to try.
 

ranma21

Supporting Vendor
Joined
Apr 18, 2005
Messages
3,323
Location
Houston, TX
Good deal. I was just going to offer to send you some immobilizer parts to try.

Thanks appreciate your generosity:) this is the culprit. And also the same year LX ECU with key will not work in the LC, there must be a difference for immobilizer as well, swapped in the LX ECU and it will not recognize the LX key as well.

89782-33020

3C57C681-FA23-42C3-BAC0-A54B1483330D.jpeg
 
Last edited:

Users who are viewing this thread

Top Bottom