1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

99 3.4 FOR THE LOVE OF GOD PLEASE HELP!!!

Discussion in 'Tacoma (Gen 1) - 4Runner (Gen 3)' started by ZWidener, Aug 8, 2017.

  1. ZWidener

    ZWidener

    Messages:
    26
    Media:
    8
    Likes Received:
    6
    Joined:
    Oct 11, 2015
    Location:
    silverdale wa
    99 4Runner limited 3.4 automatic 272,000 miles.
    So this all started by replacing the knock sensors and pigtail, while working my way back out of the motor and putting everything back together I replaced all six fuel injectors because three of the factory o'rings just fell apart after 272,000 miles new upper and lower intake gaskets ,plugged all the vacuum hoses back in and started it up and it ran like absolute garbage, idled at about 450 to 500 RPMs was very sluggish on the throttle and bellowed out white smoke that smelled of fuel. So I took everything back apart to find that one of the brand new intake plenum gaskets had a factory defect and was allowing coolant into the cylinder directly in front of the driver. So I cleaned everything, bought new gaskets installed them put everything back together except the coil packs and spark plugs and turned over the motor until all of the fluid was out. Started it back up still the same problem ran like garbage low idle wanted to stall, honestly it sounded like it was a built race motor with a gnarly cam in it. So far I have replaced the mass air flow sensor, the idle air control valve, all six injectors, the three coil packs, all the spark plugs and wires. I took the plugs out and ran the engine again while looking down with a flashlight to see if anything was stuck and five out of six cylinders seem dry, but the middle cylinder on the driver side is getting fuel dumped into it. Does anyone have any idea what this could be? My next item to replace is going to be the fuel pressure regulator unless anyone has any better ideas.
    Thanks
     
  2. White Stripe

    White Stripe

    Messages:
    4,321
    Likes Received:
    2,391
    Joined:
    Jan 6, 2012
    Is it still bellowing white smoke or just running rough?
     
  3. ZWidener

    ZWidener

    Messages:
    26
    Media:
    8
    Likes Received:
    6
    Joined:
    Oct 11, 2015
    Location:
    silverdale wa
    At idle it is a bit Smokey, drive it down the road and it's a cloud machine, and after maybe 200 yards, it will stall. It will start right up(still running like crap) and make it back to the driveway
     
  4. ZWidener

    ZWidener

    Messages:
    26
    Media:
    8
    Likes Received:
    6
    Joined:
    Oct 11, 2015
    Location:
    silverdale wa
    One of the brand new injectors was faulty and stuck wide open, replaced with an old one runs fine now but I'm getting an intermittent cylinder number 6 misfire p0306. Any thoughts?
     
  5. N22

    N22

    Messages:
    66
    Media:
    9
    Albums:
    1
    Likes Received:
    69
    Joined:
    Dec 27, 2016
    Location:
    North East
    What cylinder was the bad injector on?
     
  6. ZWidener

    ZWidener

    Messages:
    26
    Media:
    8
    Likes Received:
    6
    Joined:
    Oct 11, 2015
    Location:
    silverdale wa
    The bad injector was on cylinder #4, I'm going to swap number 6 out and see if that works