97' FZJ80 Transmission Funkiness - No Overdrive (1 Viewer)

Joined
May 20, 2021
Messages
25
Location
MN
1997 FZJ80 Automatic transmission. Shifts smooth through all of the lower gears but won't kick down into overdrive. Overdrive button is broken, clicks but doesn't really do anything. No light on dash. Get up to highway speed and its sitting at 2700+RPM. If you touch in the main shift button it drops down and almost feels like it's dropping into overdrive. The issue started when the drive seemed to flutter in and out of OD when on the highway, but now it doesn't seem to want to engage at all by itself.

Recently snagged this thing so hopping in the middle to do some troubleshooting.
  • Kickdown cable seems to be adjusted about as far as you can go. Some slack in the cable but not a crazy amount
  • Checked the ATF. Looks clean enough to me, was reading a bit low after running it according to the manual. Topped it off and check again after running it and it's right within the Hot marks.
  • It does have a 2in lift and 33s on it but I can't imagine that would impact this
Looking to see if anyone has any ideas before I run it to the dealer or shop to get looked at. I'm not sure what else to look at besides maybe an electrical issue.
 
Joined
Dec 8, 2006
Messages
10,065
Location
New Jersey
It's an electronically controlled transmission. If the OD button is not working, then it won't go into 4th gear.
It's also possible that the OD OFF dash light is burnt out.

Always check the simple things first.
 

Users who are viewing this thread

Top Bottom