96' Headlights Randomly Coming On While Vehicle is Off and Locked (4 Viewers)

Joined
Feb 10, 2017
Messages
1,111
Location
Seattle
Alright Electrical Gurus -

I'm stumped.
For the last year or so i've had my headlights randomly coming on at night, day, whenever, when the vehicle is locked and in park.
This morning I got a call that my headlights were on... the switch was on, but they turn off with the vehicle.
I've also had this happen with the switch OFF.
I replaced the headlight relay a few months ago which seemed to solve the issue at the time.
Additionally i replaced the fuses as they were original and didn't look great, but were not popped.
I'm stumped. I've checked wiring, haven't found any cuts/nicks or something. I can't believe another OEM relay already failed.
I'm running the 8005/06 bulbs trimmed to fit if that makes any difference.
Searched and didn't find anything similar. Anyone have any ideas?
 

clx16

SILVER Star
Joined
Oct 26, 2017
Messages
1,529
Location
Alpharetta GA
Have you checked for a short? Grab the wires and wiggle them around up front. The short to ground right? Is it low beams or brights?

I accidently shorted mine and they came one once.
 
Joined
Feb 10, 2017
Messages
1,111
Location
Seattle
Have you checked for a short? Grab the wires and wiggle them around up front. The short to ground right? Is it low beams or brights?

I accidently shorted mine and they came one once.
Low beams. I haven't found any shorts anywhere looking through the engine bay. I'll take a deeper dive though, that would make sense. I wonder if having other items on the shared ground could cause it. The weird thing is it'll randomly happen after sitting a few days, not right after turning off the truck or something.
In this case the cruiser has been parked a week, no issues, til this AM they came on.
 

77mustard40

SILVER Star
Joined
Nov 28, 2010
Messages
1,848
Location
Austin, TX
Do you have one of the port installed security systems? Just a guess as my lights come on for 30 seconds when I lock or unlock with my key fob which is part of arming the 1990's era security system.
 
Joined
Feb 10, 2017
Messages
1,111
Location
Seattle
Do you have one of the port installed security systems? Just a guess as my lights come on for 30 seconds when I lock or unlock with my key fob which is part of arming the 1990's era security system.
I do. Wondering if that could be the culprit. It’s worked fine 99% of the time (besides the few times it’s been totally unresponsive for a bit of time). Id really love not losing the fob access.
 
Joined
Jul 17, 2018
Messages
1,454
Location
LUGOFF, SC
I consider myself lucky, The Bean didn't come with a fob, so I never got used to it.
The security system locked my out a couple times while I was working on the truck, luckily the spare key was in the house.
I ripped The Bean's system out by the roots one day after it angered me enough.
 
Joined
Jul 24, 2006
Messages
58
Location
Fairfax, VA
@Wompom you ever figure this out?

i swear mine is doing the same thing. i usually turn the switch OFF, but last night let it do its auto thing as a test and meant to double check that all the doors were fully shut and the head/tail lights off (but got distracted by my kid), and came out this morning to dim headlights and a dead battery, so its on a charger now. i don't think the parking lights were on, and i didn't think to check the tails or license plate. i was heading to work so didn't have time to pull out a DMM and test away either.

i swear sometimes the headlights will "wake up" and turn back on if i open/close the drivers door to get something out of it in the driveway. but not repeatable and mostly question my sanity.

my other post on this topic
 
Joined
Feb 10, 2017
Messages
1,111
Location
Seattle
@Wompom you ever figure this out?

i swear mine is doing the same thing. i usually turn the switch OFF, but last night let it do its auto thing as a test and meant to double check that all the doors were fully shut and the head/tail lights off (but got distracted by my kid), and came out this morning to dim headlights and a dead battery, so its on a charger now. i don't think the parking lights were on, and i didn't think to check the tails or license plate. i was heading to work so didn't have time to pull out a DMM and test away either.

i swear sometimes the headlights will "wake up" and turn back on if i open/close the drivers door to get something out of it in the driveway. but not repeatable and mostly question my sanity.
Not completely. I replaced the headlight relay and it seemed to stop but I noticed it do it once the other day again. Chased a billion things and not sure what it is.
 
Joined
Jul 24, 2006
Messages
58
Location
Fairfax, VA
dang

i hate to say it, but i don't think changing the headlight relay would change anything. i know my lights switch off proving the relay isn't sticking, but like you, feel they turn back on spontaneously. based on my understanding of the EWD, the ONLY way they can do that is if the headlight relay coil (on pin 4) gets re-energized by the light retainer relay. but i'm not smart enough to figure out how that can happen, or the role of the diode. the tail lights don't have a diode, if anyone can explain that i'd be grateful.
 
Joined
Dec 8, 2006
Messages
10,290
Location
New Jersey
Website
www.sdsysdesign.com
dang

i hate to say it, but i don't think changing the headlight relay would change anything. i know my lights switch off proving the relay isn't sticking, but like you, feel they turn back on spontaneously. based on my understanding of the EWD, the ONLY way they can do that is if the headlight relay coil (on pin 4) gets re-energized by the light retainer relay. but i'm not smart enough to figure out how that can happen, or the role of the diode. the tail lights don't have a diode, if anyone can explain that i'd be grateful.
I agree. The headlight relay is not the issue. The light retainer relay, called "Light Auto Turn Off" in the EWD, runs both the head and tail relays. One would assume that if the low beams are magically coming on, then the tail lamps and side markers are as well. One would need to verify this before proceeding further.

You could also remove the light retaining relay, jump pins 7-3 and 8-2 on the connector, and lights will function normally from the stalk switch.
 
Last edited:
Joined
Jul 24, 2006
Messages
58
Location
Fairfax, VA
well it did it again overnight. drove the truck to get dinner, and when i got home i left the headlight switch in the full on position. when i opened the drivers door the dash lights extinguished, as did the headlights. exterior and interior were fully dark. i locked the truck w/ the key.

came out this morning to find the low beams on, parking lights on, tail lights on, dash lights on. interior overhead lights NOT on. opening and closing the drivers door kept everything on. switched the headlight switch off manually.

not sure what to test, but its got to be that light retainer relay, right? how and why is it switching the ground back on all by itself? i do still have the TVSS system (not the RS3000) installed, but disabled on the dipswitch as i have no fobs. i don't quite understand if the TVSS has control of the lights?

i did have it on a charger so the battery isnt completely dead. all this cant be good for this new AGM battery
 

Users who are viewing this thread

Top Bottom