93 hiace over fueling upon start up. (1 Viewer)

cruisedeisel

Toyota's for life
Joined
Feb 5, 2009
Messages
1,808
Location
Courtenay, vancouver island
Not sure if this is the right place to post but it is a Toyota. lol

So I have a 1993 3.0l efi Turbo diesel hiace.

If the glow light comes on when you put the ignition to start, it starts up just fine and runs perfectly.

If you turn the ignition to the on position and the glow light doesn't come on, it turns over, fires and then immediately over fuels and dies. Lots of black smoke. Time and time again.

Now if you disconnect the positive on the battery, ark it a couple times and re c-connect it, the van usually starts up and runs perfectly fine as long as the glow light comes on upon start up.

Its a mystery to me. Any help would be greatly appreciated.

Thanks!
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
7,368
Location
Victoria, BC, Canada
Not sure if this is the right place to post but it is a Toyota. lol

So I have a 1993 3.0l efi Turbo diesel hiace.

If the glow light comes on when you put the ignition to start, it starts up just fine and runs perfectly.

If you turn the ignition to the on position and the glow light doesn't come on, it turns over, fires and then immediately over fuels and dies. Lots of black smoke. Time and time again.

Now if you disconnect the positive on the battery, ark it a couple times and re c-connect it, the van usually starts up and runs perfectly fine as long as the glow light comes on upon start up.

Its a mystery to me. Any help would be greatly appreciated.

Thanks!

Is it a 1KZTE engine or 5LE? If it's 1KZTE, it's common for capacitors in the ECU to fail and leak dielectric all over the circuit board. Not only is the capacitor no longer working, but this stuff that leaks out eats the copper on the circuit board. After a while things stop working. Might be worth pulling it and opening it up to see how it looks. Look for this (black goo):

comp.jpg.57cbe6ec36401a83f3a9734e05acd250.jpg
 

cruisedeisel

Toyota's for life
Joined
Feb 5, 2009
Messages
1,808
Location
Courtenay, vancouver island
Is it a 1KZTE engine or 5LE? If it's 1KZTE, it's common for capacitors in the ECU to fail and leak dielectric all over the circuit board. Not only is the capacitor no longer working, but this stuff that leaks out eats the copper on the circuit board. After a while things stop working. Might be worth pulling it and opening it up to see how it looks. Look for this (black goo):

comp.jpg.57cbe6ec36401a83f3a9734e05acd250.jpg
Good question about the engine, I actually don't know what engine it is. I will dig into it today.
 

cruisedeisel

Toyota's for life
Joined
Feb 5, 2009
Messages
1,808
Location
Courtenay, vancouver island
I found the ECU is the passenger side B pillar. No melted goo. But I found two capacitors that are compromised. Corroded where they are soldered to the circuit board. i gave it a tiny wiggle and one side snapped.

Crossing my fingers and bringing it to the electrical wizard here in the valley.
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
7,368
Location
Victoria, BC, Canada
I found the ECU is the passenger side B pillar. No melted goo. But I found two capacitors that are compromised. Corroded where they are soldered to the circuit board. i gave it a tiny wiggle and one side snapped.

Crossing my fingers and bringing it to the electrical wizard here in the valley.

That could very well be your issue then! If you don't have luck with repair up there, I could do it for you (I'm an electronics technologist and have worked in electronics for 20 years). I've repaired ECU's before including 1kzte.
 

cruisedeisel

Toyota's for life
Joined
Feb 5, 2009
Messages
1,808
Location
Courtenay, vancouver island
That could very well be your issue then! If you don't have luck with repair up there, I could do it for you (I'm an electronics technologist and have worked in electronics for 20 years). I've repaired ECU's before including 1kzte.
Thanks for the offer. It doesn't look that hard but I do have an electronics geek. Plus he's almost free. 6 pack of budweiser free. lol But he is good.
 

cruisedeisel

Toyota's for life
Joined
Feb 5, 2009
Messages
1,808
Location
Courtenay, vancouver island
Thanks for the offer. It doesn't look that hard but I do have an electronics geek. Plus he's almost free. 6 pack of budweiser free. lol But he is good.
Hey man! Thanks a million. I replaced the two capacitors ant everything works perfect. I owe you more than a beer. Maybe I will have to try to make it to a cruiser meet to repay. What a needle in a hay stack.
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
7,368
Location
Victoria, BC, Canada
Hey man! Thanks a million. I replaced the two capacitors ant everything works perfect. I owe you more than a beer. Maybe I will have to try to make it to a cruiser meet to repay. What a needle in a hay stack.

Awesome, that's great to hear; you're welcome. Would have been a hard thing to trace down otherwise. Beers fine. :beer: :D
 

Users who are viewing this thread

Top Bottom