93 fzj80 intermittently cuts out while giving it gas (1 Viewer)

Joined
Apr 16, 2021
Messages
9
Location
Oregon
I have a 93 fzj80 that randomly cuts out/bogs down when I try to give it gas. It seems to only happen after its warmed up for a while then out of nowhere it will start sputtering and cutting out and won't rev up. Sometimes it will clear up in a few seconds, sometimes I have to shut it off and wait a few minutes then it will run ok. I jumped the fuel pump relay to rule it out and it still happened. All my wiring seems to be in good shape and iv tried wiggling the harness and connectors to see if there's a short somewhere and can't get it to change doing that. It will also happen just sitting in my driveway too. It seems to be happening more often. I'm thinking it might be the fuel pump but I'm not really sure. Hard to test anything when it happens randomly. Is there a way to test the fuel pump when the truck is running to see if thats my issue? Any help is appreciated.
 
Joined
Apr 16, 2021
Messages
9
Location
Oregon
Just saw your thread
Was yours intermittent or all the time? When it happens to me I can't even drive it
 
Joined
Mar 14, 2020
Messages
146
Location
california
Was yours intermittent or all the time? When it happens to me I can't even drive it
Started as intermittent and then 100% all of the time. I replaced all the fuel delivery items including the fuel pump and the last item I replaced that fixed my issue was the ICM.
 
Joined
Apr 16, 2021
Messages
9
Location
Oregon
I finally got it to act up again and when I sprayed it with starting fluid it cleared it up. Would that indicate that its fuel related?
 

Users who are viewing this thread

Top Bottom