'78 fj40 won't idle

Discussion in '40- & 55-Series Tech' started by montana78, Aug 17, 2006.

  1. montana78

    montana78

    Messages:
    1
    Likes Received:
    0
    Joined:
    Aug 17, 2006
    Location:
    Livingston, Montana
    [FONT=Verdana, Arial]My '78 fj40 won't maintain an idle. I can start the engine and can keep it going if I rev it. If I depress the pedal half way it cycles from low to high rpms. The fuel level in the float bowl remains at halfway. The emission system was removed by a previous owner and all open vaccum links have been plugged. I have checked these and all remaining vaccum links and haven't found a leak. I replaced the needle and adjusted the float on the carb a few months ago before this problem showed up. Is this a fuel pump problem, or something else? Note: This problem arose suddenly while driving down the road. The engine suddenly lost power and I had to depress the gas pedal to the floor to get it to go.
    [/FONT]
     
  2. dfmorse

    dfmorse

    Messages:
    1,518
    Likes Received:
    2
    Joined:
    Jul 7, 2004
    Location:
    EVERGREEN, CO, USA
    The first thing I would do is to check for an inline fuel filter; install a new one if u have one. How old is the fuel pump; a new fuel pump for $125 from ur dealer may solve the problem.

    ...
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.