77 BJ40 with B engine - adding A/C and need crankshaft pulley with 2 grooves

Joined
Nov 23, 2019
Messages
3
Location
Houston, TX
Hi all. First time poster and newbie to LC ownership. I bought this vehicle in Costa Rica and had it shipped to Texas. They installed A/C before shipping it to me, then turns out they simply used a longer belt to tie crankshaft, alternator, water pump, and compressor. Needless to say, the battery wasn’t charging, due to the alternator not spinning correctly.

After some research, I’ve learned that the B engines came up single-groove pulleys only. I saw a thread taking about a smaller second groove on pulleys for vehicles in late 60s (IIRC, it was talking about Toyota preparing for updated emissions standards so they added a second smaller pulley). Found some other threads on these pulleys but really am more interested in what options I have to get this fixed. I’m up for buying a pulley, though there may be an issue with the harmonic balancer that requires a custom fit and the vehicle to be present. But at this point, I’ll try anything, short of upgrading to a 3B engine.

Any ideas? Anyone got an extra fabricated pulley or perhaps a pulley that might work?

Here are pictures of my current pulley setup.

Thanks,
Sam

EDAAE1D7-4727-482E-81D5-9B4DB23663C3.jpeg


FA48A737-DDD2-4CCD-9188-37E6588006F5.jpeg


142B3603-5409-494F-B50C-4091DDB3C230.jpeg


DA0558A0-47A2-46C5-86DB-7BA132C14ED8.jpeg
 
Joined
Nov 23, 2019
Messages
3
Location
Houston, TX
Oh, forgot to mention that my mechanic added a tensioner to try to fix it. Now the belt squeals like no other when you turn on the A/C. Doesn’t make any noise when A/C is off though, only when it’s on.
 
Joined
Mar 16, 2010
Messages
522
Location
Rossland BC
after 81/82 can spec 3B’s with power steering came with a double grove

... but a proper new belt the right size is likely the fix.

and that depends on; what A/C was put in, do all the ‘pulleys’ have the same grove, are they aligned...
 
Joined
Nov 23, 2019
Messages
3
Location
Houston, TX
With the 4 pulleys and where the A/C was mounted, 2 different mechanics have said it’s not possible for there to be enough tension. The first mechanic welded on a tensioner (you can see it in one of the pics) and he’s the one who found a belt long enough to wrap through the 4 pulleys and the tensioner. He also said the A/C pulley is not aligned correctly.

He then ran out of time to work on the LC, so I took it to a guy who specializes in these vehicles. He seems to be the premier guy in houston for these vehicles. He’s also saying it won’t work with 1 belt on 4 pulleys, and that we need to find a crankshaft pulley with 2 grooves or have one made. He’s very busy so He doesn’t work on my vehicle too often. But man oh man I’d love to get that vehicle out of his shop as it’s been there for 1.5 years!!!
 

Users who are viewing this thread

Top Bottom