62 smog pump thread broke (1 Viewer)

Joined
Apr 23, 2020
Messages
25
Location
San Diego, CA
recently I had to replace my alternator and noticed the smog pump was missing a brace. Ordered the bracket to only notice the pump thread was broken.
A8D62DE9-D57F-4C24-8229-67792B1FA653.jpeg

For better visual, here is the bracket on the pump. Clearly there are no threads to bolt it down.
2AFF84C7-AE6B-432A-9672-C7C991B793B3.jpeg


I drove this from Sacramento to San Diego and two family trips. little frustrated to find this, to say the least. I prefer to not buy a pump just for this threading when the pump is seemingly still good.

so do I simply zip tie this thing down or any other method you can suggest?
 
Joined
Nov 25, 2014
Messages
486
Location
Western victoria Australia
Isn't that bolt screwed in? Heat + wd40 and vice grips might loosen it up.
Or drill a hole in a bar [like the bottom pic] and weld the bolt end to the bar, and try and free it up.
Or a nut with the right size hole welded to the bolt end would be a better idea.
 
Last edited:
Joined
Apr 23, 2020
Messages
25
Location
San Diego, CA
Isn't that bolt screwed in? Heat + wd40 and vice grips might loosen it up.
Or drill a hole in a bar [like the bottom pic] and weld the bolt end to the bar, and try and free it up.
Or a nut with the right size hole welded to the rod would be a better idea.

you’re right. Shortly after postingI noticed that it’s a bolt screw. Waa already exhausted and frustrated from work to take extra minute to think/look at everything before posting.:bang:

appreciate the feedback
 

Users who are viewing this thread

Top Bottom