62 series auto problems?!?!?!?!?

Discussion in '60-Series Wagons' started by dgfj40, Feb 18, 2009.

  1. dgfj40

    dgfj40

    Messages:
    14
    Media:
    10
    Albums:
    2
    Likes Received:
    0
    Joined:
    Dec 23, 2008
    i have recently done a 3f to 2f conversion to my 62 series cruiser. it is an automatic with a vaccum operated transfer case.
    The autiomatic is making my motor overheat and is very gutless. What could be the cause of this and how can i fix it?
     
  2. euclid

    euclid

    Messages:
    5,988
    Media:
    14
    Albums:
    1
    Likes Received:
    365
    Joined:
    May 15, 2002
    Location:
    Jackson, MS
    search and ye shal find
     
  3. tonkota

    tonkota

    Messages:
    2,130
    Media:
    1
    Likes Received:
    4
    Joined:
    Sep 28, 2004
    Location:
    Spokane, WA
    Huh? Your transmission is making your engine overheat? How does that work?

    Is your transmission getting very hot? Do you have an aux. transmission cooler? I have a 2F-E and have not had this problem.
     
  4. dgfj40

    dgfj40

    Messages:
    14
    Media:
    10
    Albums:
    2
    Likes Received:
    0
    Joined:
    Dec 23, 2008
    i can leave it running and it dose not get hot but when i put it into drive and start driving it gets hot very quick it has me beet
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.