4X4 Labs HD tie rod & relay rod install

alex e

SILVER Star
 
Joined
Apr 1, 2006
Messages
1,827
Location
Dallas
Did I do this correctly? Saginaw PS going in next.













Not sure if everything is in the right spot. What I noticed is the tie rod end is a smaller diameter than the holes in the steering arms. Should they be snug in there?
 

John Smith

In the garage
 
 
Joined
Jun 7, 2004
Messages
4,206
Location
Maryland
The TREs are supposed to be mounted under the steering arms. In your pictures the passenger is mounted from the top while your driver is correct and mounted from below. And they should fit snug in the bore with zero slop when tightened.
 
Joined
Nov 21, 2008
Messages
180
Location
Ramer Alabama
passenger side tre should hang from the bottom of the lc steering rod. other than that it looks good.

The play in the ends will go away after the nut's are tightend up the tre's are cone shaped.
 

alex e

SILVER Star
 
Joined
Apr 1, 2006
Messages
1,827
Location
Dallas
They are loose in the hole....pic:



However the TRE has a shoulder that matches the taper ID of the steering arm, and that is orientated with the nut facing down, on both sides. So either these were tapered incorrectly (upside down) or that's the way 4X4 Labs wants them to be orientated. The only way these will fit is upside down, and still connect to the Saginaw gearbox shaft, and fit the TREs into the taper of the steering arms. Look how nice and snug the fit is in picture 2. Picture 4 shows the inexact fit, but not so well.

:confused:
 
Last edited:
Top Bottom