3B head installed - engine keeps cutting offbracket

Discussion in 'Diesel Tech / 24 volts' started by bj70alex, Jul 2, 2005.

  1. bj70alex

    bj70alex

    Messages:
    416
    Likes Received:
    2
    Joined:
    Feb 28, 2003
    3B head installed - engine starts but keeps cutting off

    Hi,

    Finaly after more two month i put everything tohether, bled the system using the primer pump. It starts, but after about two minutes the engine cuts off.
    I did bled it twice and made sure that a clear stream of fuel is coming out.
    Do you guys know why the engine keeps cutting off?

    Thanks,
    Alex
     
    Last edited: Jul 2, 2005
  2. crushers

    crushers post ho

    Messages:
    22,191
    Likes Received:
    192
    Joined:
    Feb 10, 2004
    Location:
    Tara Ontario
    could be a couple reasons, air still in the line or loose conection at the iol sensor... are my guesses... sometimes it can be a bear to get rid of all the air in the fuel systems...
     
  3. wesintl

    wesintl

    Messages:
    4,520
    Media:
    1
    Albums:
    1
    Likes Received:
    34
    Joined:
    Mar 14, 2003
    Location:
    Between Here and There
    Did you see oil on the rockers?
     
  4. bj70alex

    bj70alex

    Messages:
    416
    Likes Received:
    2
    Joined:
    Feb 28, 2003
    Wayne,

    Sorry for my ignorance, but what IOL Sensor are you talking about?

    Alex
     
  5. bj70alex

    bj70alex

    Messages:
    416
    Likes Received:
    2
    Joined:
    Feb 28, 2003
    I think so, but I will double check.
     
  6. crushers

    crushers post ho

    Messages:
    22,191
    Likes Received:
    192
    Joined:
    Feb 10, 2004
    Location:
    Tara Ontario
    IOL is Wayne's way of spelling OIL...
     
  7. bj70alex

    bj70alex

    Messages:
    416
    Likes Received:
    2
    Joined:
    Feb 28, 2003
    Wayne,

    I had to crack the injecttors and got her running. But I screwed up the oil gauge. I thought that I missing the connector for the center of the sending unit, wrong. I was missing the ground connector. So what happened was, I connected the ground to the center and the black connector to the ground. When I turned the key, I saw the oil gauge needle was way past high. I reveresed them and now I my oil pressure gauge is DEAD. I can probably will install the mechanical gauge later on. How much is the good used one for 12V?

    Thanks,
    Alex
     
  8. crushers

    crushers post ho

    Messages:
    22,191
    Likes Received:
    192
    Joined:
    Feb 10, 2004
    Location:
    Tara Ontario
    suggestion, mech gauges are cheap, i would stick one in now and be done with it...
    cheers
     
  9. Greg_B

    Greg_B

    Messages:
    4,457
    Likes Received:
    147
    Joined:
    Mar 28, 2002
    Ahhh, yes. The famous 710 cap.

    :D

    gb
     
  10. bj70alex

    bj70alex

    Messages:
    416
    Likes Received:
    2
    Joined:
    Feb 28, 2003
    Any suggestion where is the good place to install it?
     
  11. Greg_B

    Greg_B

    Messages:
    4,457
    Likes Received:
    147
    Joined:
    Mar 28, 2002
  12. wesintl

    wesintl

    Messages:
    4,520
    Media:
    1
    Albums:
    1
    Likes Received:
    34
    Joined:
    Mar 14, 2003
    Location:
    Between Here and There
    When you guys talk of the rear plug, is this the one you're talking about? It's beind the oil cooler.
    111_1121.JPG
     
  13. Greg_B

    Greg_B

    Messages:
    4,457
    Likes Received:
    147
    Joined:
    Mar 28, 2002
    No. If my eyes are correct, it is the 10mm plug to the left of your mark. You should see at least three of those plugs along the oil gallery that runs from front to back on that side.

    gb
     
  14. wesintl

    wesintl

    Messages:
    4,520
    Media:
    1
    Albums:
    1
    Likes Received:
    34
    Joined:
    Mar 14, 2003
    Location:
    Between Here and There
    No.. those are bolts for the cooler. If I'm seeing them right they are in the block below the cooler. I see two of them one almost under the cooler and one in the very back almost near the bellhousing. Let me see if I can grab a pic. I had to get under the truck to see them.
     
  15. wesintl

    wesintl

    Messages:
    4,520
    Media:
    1
    Albums:
    1
    Likes Received:
    34
    Joined:
    Mar 14, 2003
    Location:
    Between Here and There
    Ok.. here is looking up. THe upper left is the exhaust the middle is the blow by tube with the oil cooler above. Both look like they have the 1/8 bsp theads. So when you guys say rear, the one to the left in the very rear or the one in the middle which is circled on the right?
    111_1122.JPG
     
  16. Greg_B

    Greg_B

    Messages:
    4,457
    Likes Received:
    147
    Joined:
    Mar 28, 2002
    Beat me too it...:D

    Yup, below where I was mentioning.

    There is a plug right at the rear of the block, one right below the oil cooler section in your pic, one for the stock oil sender in front of the oil cooler, (there is another sender on the oil cooler), then one more plug right at the front of the block.

    I took the one right at the rear for the gauge on my BJ42.

    gb
     
    Last edited: Jul 3, 2005
  17. wesintl

    wesintl

    Messages:
    4,520
    Media:
    1
    Albums:
    1
    Likes Received:
    34
    Joined:
    Mar 14, 2003
    Location:
    Between Here and There
    Awesome, Thanks! Something I would have never known about or looked for without this board :D

    It's easy to see following the galley rib and I spotted the first one too, thanks. When you say there is one on the oil cooler, isn't that the one a circled in the first pic?

    Sorry for the hijack there Alex. ;)
     
    Last edited: Jul 3, 2005
  18. Greg_B

    Greg_B

    Messages:
    4,457
    Likes Received:
    147
    Joined:
    Mar 28, 2002
    I don't know the correct ports on the oil cooler, other then one that the stock sending unit screws into. That is the one I am referring to.

    gb
     
  19. bj70alex

    bj70alex

    Messages:
    416
    Likes Received:
    2
    Joined:
    Feb 28, 2003
    Wes,

    Don't worry about the hijack, always nice to learn new things about 3B.

    Alex
     
  20. Tapage

    Tapage Club 4X4 Panamá SILVER Star

    Messages:
    23,126
    Likes Received:
    1,251
    Joined:
    Apr 4, 2003
    Location:
    Panamá
    and the 3B engine start . ? ( and keeps alive .. ? )
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.