2nd Barrel not opening!!!

Joined
Apr 18, 2005
Messages
174
Location
New York, NY
Visit site
After countless hours tuning, timing and fabricating makeshift superchargers, I finally have ascertained that my second barrel is not opening in any way shape or form. This is extremely exciting in that it explains a lot of my horsepower woes, but frustrating because I can't make the second barrel work without me being under the hood like the little dinosaur in the Flinstones' radio, making it work manually. Oh but when I did twist open that second barrel she let out a mighty roar that I haven't heard in 5 years owning the rig!

My first question is, what is supposed to open the second flap? I gotta think it's the red stickered diaphragm but that brings up two new problems:

1. The secondary diaphragm doesn't actuate under any RPM.

2. Even if the diaphragm was working, I can't see it hooking up with the shaft in any way that would cause it to turn. The two little tabs seem to be oriented so that when I manually contract the diaphragm, the tab and spring just rotate around the shaft, never reaching the stationary tab that would rotate the shaft. I found a pretty detailed picture of another carb and mine appears to be oriented the same way. On a side note, I forced them into an orientation I thought made sense and it caused the engine to refuse to work at all.

So is my secondary diaphragm faulty? And if so, how would it actuate the second barrel even if it was working?

Then again, maybe this is my chance to convince wifey that we need a Weber:hmm:
 

2mbb

SILVER Star
Joined
Sep 1, 2003
Messages
5,244
Location
WC, CA
Visit site
You will need to replace the secondary diaphragm to get it to work. You can purchase one from toyota. I am told by good authority that the secondary diaphragm that comes with some aftermarket kits (such as the Hygrade kit) are for the earlier 2F engines, not the engine in the FJ60).

I doubt that you can get the truck to run properly with secondary properly open in your garage. The secondaries are designed to be used under high load conditions and you can not simulate that without a dyno or a proper engine testing stand.

I belive the picture below is correct (from SOR's website).
2f carburetor front.jpg
 
Joined
Apr 18, 2005
Messages
174
Location
New York, NY
Visit site
Ok, no movement with the paperclip. This isn't too surprising--I can get a replacement in about a week.

The bigger problem is that I can operate the diaphragm rod manually and I can operate the second butterfly manually, but the two don't seem to interact with each other in a cause/effect relationship. If I pull the diaphragm rod the linkage and spring just wind up and never end up hooking up with the butterfly shaft.
 
Joined
Apr 18, 2005
Messages
174
Location
New York, NY
Visit site
Is it the binding of the spiral spring on the shaft that causes the shaft to turn or is there actual tab on tab contact?

This is seriously giving me fits. Virtual 12 pack if someone can just pop the hood and tell me what mechanism causes the shaft to turn. I'd be seriously grateful.

Again, I've established that my diaphragm is bad.

Thanks!
 
Joined
Apr 18, 2005
Messages
174
Location
New York, NY
Visit site
Thanks for that, it's a great resource and shows lot's of pictures of the diaphragm, which I will use to reassemble the diaphragm later, but I still can't find anything describing or showing the mechanism between the diaphragm rod and the shaft that gets turned:bang:.

I've spent a couple hours connecting it in every possible configuration I can imagine.
 

2mbb

SILVER Star
Joined
Sep 1, 2003
Messages
5,244
Location
WC, CA
Visit site
There is really only one way the secondary diaphragm can be connected. See the picture in my previous post. The secondary valve will not open unless the primary valve is open. With the truck engine turned OFF, fully open the primary throttle by hand using the throttle linkage. If you pull up diaphragm rod, it should also allow the secondary valve to fully open. Closing the primary will also close the secondary, even if the diaphragm is still pulled in. There is linkage on the back side of the carb that controls this interaction of primary and secondary valves.
 
Joined
Apr 18, 2005
Messages
174
Location
New York, NY
Visit site
I appreciate and I am 100% in agreement with everything you are explaining, except that my no matter how I hook things up the diaphragm rod doesn't turn the butterfly shaft.

It just spins freely. :bang::bang::bang:
 
Joined
Apr 18, 2005
Messages
174
Location
New York, NY
Visit site
I've marked one facet in red for clarity. The L-shaped piece is connected to the butterly shaft. The lobe-shaped piece is the part that moves when the diaphragm contracts. Here is a shot of the assembly at rest:

carb002.jpg


Here's the assembly as if the diaphragm was contracted:

carb003.jpg


You'll notice the shaft hasn't moved (and it's not because it's being blocked on the other side)

I can only think of three things:

1. The L-Shaped tab is supposed to push on the lobe-shaped tab (this seems most likely but wouldn't match any pictures I've seen and doesn't really work for various reasons.)
or
2. The Spring is supposed to be wound so tightly that it causes the shaft to turn (unlikely because I've tried it and it's impossible to get that tight--plus the spring seems too weak to work like that for long)
or
3. There's a piece missing that a previous owner lost
 
Joined
Apr 18, 2005
Messages
174
Location
New York, NY
Visit site
New version of the same problem.

I recently pulled the carb and cleaned it throughly, installed a new secondary diaghram, and threw on a new F series manifold gasket while I was at it. The carb is working awesome--the other day I hit 80MPH GPS speed on the freeway for the first time but again I'm 99% sure the second barrel isn't opening. I've run it for three days with a paper clip right up next to the diaphragm and it's still there now.

Current status: Linkage mechanism appears to be operating perfectly. I can manually pull the secondary diapragm arm to actuate the second barrel.

Current problem: Diapragm isn't retracting.

Hypothesis: No vacuum to the diaphragm--seal is tight and diaphragm is brand new.

Solution: I don't know!

Questions: How does vacuum get to the little secondary port? Does the little teeter totter valve at the base of the carb actuate it and if so, why might it not be working?

I had a Weber on order but I've decided to stick with the stocker per Jim C's CFM logic cited in carb discussion all over the forum.
 
Joined
May 10, 2007
Messages
1,028
Location
Snohomish, Wa
Visit site
Is it just me or are these carbs overly complicated? Seems like way too many diaphragms and moving parts. Im surprised weber carbs aren't more popular with the cruiser crowd.
 

2mbb

SILVER Star
Joined
Sep 1, 2003
Messages
5,244
Location
WC, CA
Visit site
the teeter totter valve is the slow cut valve, and it doesn't open the secondary. The vacuum port is used to pick up the vacuum being created in the main venturi. You can see in the schematic below that the port opens into the throttle bore right below the main venturi. You should shoot some carb cleaner through to make sure the port channel is not plugged.
carburetor cut away schematic.JPG
 
Joined
Apr 18, 2005
Messages
174
Location
New York, NY
Visit site
Nevermind:rolleyes:. Ten minutes after I posted that last one I got a knock at the door and it was the FedEx guy with my Weber 38. MAF said they'd call and confirm before sending it due to backorder issues at which time I was going to cancel but I guess they changed their minds.

Since I'm not one for returns...took about two hours to install it since they didn't send all the right parts and I had to fab some studs. Major mating up issues with stock air cleaner as well but I've got it sealed for now.

Boy does she cook though. Feels like a header and recurve is a must for total perfection but the low end punch is really instant and refreshing. Long live the 2F!
 
Joined
Oct 19, 2013
Messages
2,366
Location
NY
Visit site
I'm having the same problem that caserique identified in this thread up to post #11. I just rebuilt my carb and installed a new secondary diaphragm, but am pretty sure that I don't have the arm of the secondary diaphragm connected correctly to the shaft for the second barrel.

In post #12 it seems Trollhole posted an image of how to connect it correctly, but I don't see a link. Anyone got a picture of how to does this correctly? You out there Trollhole?

How nice it would be to have more power....
 
Joined
Oct 19, 2013
Messages
2,366
Location
NY
Visit site
Yeah, thanks for the reply mongoose, first thing I started with was replacing the vacuum lines. Then checking that all the emissions components were working...then seafoam treatment and valve adjustment...then carb rebuild after doing the mod on the secondary slow cut valve...

When I had the carb off and reassembling, I'm pretty sure that I got all the linkages connected correctly. When I manually actuated the primary throttle shaft, at the apex of it's rotation, if I remember correctly, it was pushing the secondary open...

But when I put the secondary diaphragm on (after the carb was mounted on the truck, since I had to wait for the order to come in), I ran into the same problem that caserique had above. But the link to the solution, post #12 in this thread, is no longer active or...?
 

Users who are viewing this thread

Top Bottom