2H oil pressure help (1 Viewer)

Joined
Mar 27, 2007
Messages
163
Location
London, Ontario, Canada
Hi guys, I need some advice on my 1986 HJ60, When I first start it up the oil pressure gauge does move at all, there is no unusual noises coming from the engine, after a few minutes the oil pressure seems to go to the "H" side of the gauge, then as the engine warms up to the oil pressure drops to a what I consider normal level. and goes up and down according to rpms, but responds very slowly.

The engine starts up great, no blow by, has anyone else experianced this sort of oil guage behavior before, should I be investing in a mechanical oil pressure gauge.

I havent been driving the rig, and if you think this is serious ill wait till i have a chance to fix it.

Please let me know what you think.
about 250K km on the engine, since the oil pressure does come up Im not suspecting the oil pump but who knows.
 
Joined
Apr 30, 2005
Messages
1,660
Location
N.Q. australia
rainforrest067.jpg

REPOST...LOL. You can see what excessive oil pressure can do to a gage on start up, then drop back to normal. Some people think the excessive pressure is good but it is not. Too much oil is going through worn bearings making clearances wrong,more oil in the rocker gear than what is required and more oil on the bore that ends up as carbon on the ring lands causing ring/bore problems. cheers
 

Tapage

Club 4X4 Panamá
Joined
Apr 4, 2003
Messages
23,562
Location
Panamá
the stock oil pressure gauge is a piece of crap. In general, if you care about oil pressure, get a real gauge.

Ditto ..

FSM advice

35 - 64 PSI @ 2000 rpm ( normal opertaive engine temp ) and at least 4 PSI@idle ( min 600 rpm )
 
Joined
Mar 27, 2007
Messages
163
Location
London, Ontario, Canada
Just a quick update, oil level is still perfect, started it up the gauge seemed to be working correctly now, Im gonna do a oil change and see what that does.
 

Users who are viewing this thread

Top Bottom