1KZTE Leaking Fuel Pump

Joined
Jan 9, 2022
Messages
16
Location
Huntsville, AL
Looking for some advice here on my 1KZTE. She runs great however I noticed an issue last month on start up. She started normally but was leaking fuel from the pump. I couldn’t determine exactly where it was coming from. I had recently done the mod to stretch the spring on the banjo bolt so I thought that may be it. I tightened it a tad and the leak stopped so problem solved…I thought. Few days ago the problem resurfaced but the leak stopped itself 10-15 minutes later. I’m starting to think this is temperature induced as both times happened when the truck was parked outside and it was extremely cold. My guess is once the truck and fuel warms up the leak stops. Are bad O-rings more susceptible to cold temps? Should I just go ahead and have it rebuilt? Thoughts on mechanical pump?
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
8,310
Location
Victoria, BC, Canada
This comes up again and again here on the JDM diesel imports. Pretty much all the pumps seem to leak at some point. It's happened to me with the two vehicles I've had. I bought a seal kit, removed the pump, re-sealed it, and re-installed. I did a timing belt job at the same time.

Paying someone to do this will cost thousands. If you can do it yourself, it'll cost you a couple hundred in parts (for pump seal kit and timing belt kit).
 
Joined
Jan 9, 2022
Messages
16
Location
Huntsville, AL
This comes up again and again here on the JDM diesel imports. Pretty much all the pumps seem to leak at some point. It's happened to me with the two vehicles I've had. I bought a seal kit, removed the pump, re-sealed it, and re-installed. I did a timing belt job at the same time.

Paying someone to do this will cost thousands. If you can do it yourself, it'll cost you a couple hundred in parts (for pump seal kit and timing belt kit).

Someone suggested that on FB group suggested that if it's leaking out of the sensor on top (which I think it might be) that it can be fixed easily with teflon tape. I might try that first before going the full rebuild. It only happens right at extreme cold start and then stops as soon as the engine warms up.
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
8,310
Location
Victoria, BC, Canada
Someone suggested that on FB group suggested that if it's leaking out of the sensor on top (which I think it might be) that it can be fixed easily with teflon tape. I might try that first before going the full rebuild. It only happens right at extreme cold start and then stops as soon as the engine warms up.

Its VERY easy to wreck that sensor. Be very careful. Please just buy the proper seal kit at least (instead of teflon tape)! This is the seller I bought from: 1KZ-TE Diesel Injection Fuel Pump Repair Kit (9) + free fitting instructions | eBay - https://www.ebay.co.uk/itm/162543919262?hash=item25d85f609e:g:pOMAAMXQ~6VQ4AVy

Here are pictures of when I did this job on my electronic pump. Should be basically the same for yours. Resealed my rotary injection pump - https://forum.ih8mud.com/threads/resealed-my-rotary-injection-pump.826009/

Note, electronic pumps don't need to be timed like the mechanical pumps. Just a matter of aligning the timing marks by eye (per manual instructions).
 
Joined
Jan 9, 2022
Messages
16
Location
Huntsville, AL
Its VERY easy to wreck that sensor. Be very careful. Please just buy the proper seal kit at least (instead of teflon tape)! This is the seller I bought from: 1KZ-TE Diesel Injection Fuel Pump Repair Kit (9) + free fitting instructions | eBay - https://www.ebay.co.uk/itm/162543919262?hash=item25d85f609e:g:pOMAAMXQ~6VQ4AVy

Here are pictures of when I did this job on my electronic pump. Should be basically the same for yours. Resealed my rotary injection pump - https://forum.ih8mud.com/threads/resealed-my-rotary-injection-pump.826009/

Note, electronic pumps don't need to be timed like the mechanical pumps. Just a matter of aligning the timing marks by eye (per manual instructions).
I'll go ahead and order the kit. I looked through your pictures/write-up and it might be a tad bit outside my skill level at the moment.
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
8,310
Location
Victoria, BC, Canada
I'll go ahead and order the kit. I looked through your pictures/write-up and it might be a tad bit outside my skill level at the moment.

At least you can see how the top of the pump comes apart. Make sure you clean the heck out of the area with brake clean and compressed air before digging in. You don't want any debris getting into the pump.
 
Joined
Oct 30, 2004
Messages
1,190
Location
Winnipeg,Manitoba,Canada.
Someone suggested that on FB group suggested that if it's leaking out of the sensor on top (which I think it might be) that it can be fixed easily with teflon tape. I might try that first before going the full rebuild. It only happens right at extreme cold start and then stops as soon as the engine warms up.
this pumps usually last a long time,you dont need a full rebuild,just a reseal,ive reseal many pumps,the hardest is the big o ring between the head and the pump body,
 

Users who are viewing this thread

Top Bottom