1HD-T leaking injection pump

Joined
Jul 6, 2006
Messages
28
Location
Vancouver, BC
Experts!

I have two leaks on the right side of my engine.
1. Power Steering pump resivoir - i am ordering the replacement
2. and this is the one I need help with - fuel pump. Here is the evolution:
a. in the colder mornings, the truck would not start, determined it was a fuel problem, pumped primer on the fuel filter, cruiser starts no problem. As I pump, I can hear air bubbles in the lines/filter
b. noticed liquid on the injector pump, but thought it was pwr steering fluid
c. sometimes, not all the time, when I over pump the fuel primer, i can see fuel leak from the cold start rod. Raj had mentioned once that these things were problematic.

Have not isolated the leak precisely, but can see that when I create pressure with the pump, see a fast drip from the bolt that holds the cold idle bar in, I but wanted to get a sense of how to proceed from the experts. I was thinking first thing, to disconnect the cold start function - never really needed it and replace fuel filter (i do that every 10K).. Is there a simple fix. Any schematics out there that show the exploded diagram of the pump? How do I disconnect it?

Thanks in advance for taking the time to help me out gents.
:cheers:
 
Last edited:
Joined
Sep 30, 2006
Messages
1,040
Location
Calgary Alberta Canada
I also have the same leak. i think it is from my injector pump too!! I removed my acsd because they do really suck if they break!!

Raj tells me that I need my pump rebuilt.. .. should colst like $1000 or a bit more

crap, plus I have to send it to him because no-one has given me a good shop in Calgary!!

All the best,
 
Joined
Feb 14, 2008
Messages
2
Fuel delivery

Hi, just joined from Prince George. The fuel delivery on my 1990 1HD-T is haywire. I have no idle but can start and run it if I keep the throttle feathered just right. It occasionally surges and also occasionally misses. I changed the fuel filter and if anything it got worse. As soon as it's below 1000 rpm it dies. All the linkages look okay and I don't see any loose fuel around the pump.

Any ideas.

cheers,
Bob
 
Joined
Nov 4, 2007
Messages
397
Experts!

I have two leaks on the right side of my engine.
1. Power Steering pump resivoir - i am ordering the replacement
2. and this is the one I need help with - fuel pump. Here is the evolution:
a. in the colder mornings, the truck would not start, determined it was a fuel problem, pumped primer on the fuel filter, cruiser starts no problem. As I pump, I can hear air bubbles in the lines/filter
b. noticed liquid on the injector pump, but thought it was pwr steering fluid
c. sometimes, not all the time, when I over pump the fuel primer, i can see fuel leak from the cold start rod. Raj had mentioned once that these things were problematic.

Have not isolated the leak precisely, but can see that when I create pressure with the pump, see a fast drip from the bolt that holds the cold idle bar in, I but wanted to get a sense of how to proceed from the experts. I was thinking first thing, to disconnect the cold start function - never really needed it and replace fuel filter (i do that every 10K).. Is there a simple fix. Any schematics out there that show the exploded diagram of the pump? How do I disconnect it?

Thanks in advance for taking the time to help me out gents.
:cheers:


I couldnt see the diaphram causing a leak, merely causing your engine to rev uncontrollably.
 
Joined
Dec 29, 2006
Messages
9,165
Location
Abby
Welcome to MUD Bob. I suggest you start a new thread for your problems rather than tagging on to someone elses thread. On a short threads like this people miss seeing the post dates.
 

Users who are viewing this thread

Top Bottom