1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1996 cruise control problem

Discussion in '80-Series Tech' started by damiand, Jul 10, 2005.

  1. damiand

    damiand

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jul 10, 2005
    I have a 1996 and the cruise control doesn't work the cruise light comes on but when I try to engage it nothing happens. The light doesn't blink or anything took it to the dealer and they say its the actuator which would cost $1500. Went to junkyard and purchased for $75. Put it on still same problem. Went back to dealer and of course they said if they would have repaired it they wouldn't have charged me for it. YEAH RIGHT!!!!!! so i'm stuck with another actuator and my problem is still not fixed.Any help would be appreciated. :confused:
     
  2. cruiserman

    cruiserman

    Messages:
    1,861
    Likes Received:
    0
    Joined:
    Mar 27, 2003
    Check the brake fluid level, and check the sensor in the cap.
     
  3. CJF

    CJF

    Messages:
    7,082
    Likes Received:
    1,131
    Joined:
    May 31, 2005
    On my '91 the problem was the speed sensor (sticking into the T-case, in line with the speedo cable). Don't know if it's the same/similar on a '96.

    Again on a '91, the FSM shows how to do very thorough diagnostics on the cruise control system. Something like: 1) Turn the key to "on" while depressing the cruise control button. If the cruise control light flashes, the such-and-such system is ok. 2) Hold the cruise control arm in the "set" position. If the light does this, then blah blah blah is ok. Etc...

    Curtis
     
  4. lx450landcruiser

    lx450landcruiser Moderator

    Messages:
    2,779
    Likes Received:
    7
    Joined:
    Sep 22, 2003
    Location:
    Uganda
    i had the same peob with my 96 lx was driving with it on then all the sudden it just stoped working
    i added some fluid later on and now it works again.


    thats my vote
    mike
     
  5. damiand

    damiand

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jul 10, 2005
    I've already replaced the brake fluid reservoir and sensor, one thing I do notice is occasionally my brake lights will sometime come on at night and stay on until I notice it, could that be the problem of it sticking barely? If so how can I adjust them?
     
    Last edited: Jul 11, 2005
  6. Mudshack

    Mudshack

    Messages:
    422
    Likes Received:
    0
    Joined:
    Mar 23, 2004
    Location:
    Lee's Summit, MO (KC)
    Dang, and i thought cruiserman was being a smart-a$$. The sensor is connected to the brake fluid senors somehow? Sheesh! I can understand if the brakes were slightly depressed that the cruise control would not engage.

    What about the problem I am having.......Set the cruise control at 70, it drops to 65 holds it there for a second, then downshifts and runs at 67 but at 3200 rpms.

    Gonna fill up the resevoir tonight. Should bleed out the entire system, brake fluid is looking pretty toasted.