1991 FJ80 A/C & Smog Pump Questions (1 Viewer)

Joined
Mar 20, 2021
Messages
47
Location
Allen Texas
Just bought a 91 FJ80 with 150k. The A/C and smog pump is disconnected. I have a few questions.
1. The check engine light is on, I assume this is the smog delete since it is a good running truck?
2. Where does your stock engine oil pressure gauge normally sit at first startup and then after driving for awhile? This one was in the middle for the first mile or so, then slowly dropped about a quarter. Something to worry about? I know these gauges are not accurate, but want to know if that is a red flag.
2. Does the smog pump rob even more power out of this engine or is it worth reinstalling?
3. A/C doesn't work. Should I replace the whole system (compressor, condenser, dryer, lines, etc.) or go compressor then move on if it doesn't work? Hate to replace and take it to a shop only to find that it's not just the compressor.
 
Joined
May 6, 2011
Messages
994
Location
Davis County, UT
Pull the codes to get direction on hour cel, it's a definite maybe. Obd1 is done via a jumper wire if you're used to newer cars.
I wouldn't be too concerned about your oil gauge. I've seen the same in a good running 60 and 80. Oil thins and becomes less viscous as it warms up, allowing for less pressure to accomplish the same flow through small orifices.
Smog pump does rob power on such a low powered engine to begin with. Not a ton, but it does. If you're required to do emissions that's an obvious yes, otherwise it's up to your conscience.

Common wear items in ac systems are expansion valve, seals, and compressor. It's a good idea to replace the drier if the system is opened, and in your case, also converting to r134a. I'd first test the system for pressure- it'll disable itself if it's too low. Don't be too quick to say the compressor is bad
 
Joined
Dec 8, 2006
Messages
9,887
Location
New Jersey
Smog pump removal will not cause a CEL on its own. Something else is in play.
Folks remove the smog pump for 2 reasons. A failed bearing or a desmog.
It is a low pressure air pump and will have very little if any effect on the 3FE. It's essentially just another pulley.
 
Joined
Nov 16, 2020
Messages
76
Location
Fatally Flat FL
Interesting info here, waiting on my overspending order from Wits End to show up before I start wrenching but taking inventory I noticed another winner on my new to me 3FE.

There appears to be zero mods to the engine, all of the air pump lines are intact as far as I can tell and I bought it in a no smog/emissions state.

However, I’m only running two belts. Even more odd to me as a newbie - am I about to jack something up when I throw all three OEM belts on?!

image.jpg
 
Joined
Nov 16, 2020
Messages
76
Location
Fatally Flat FL
Happy to! It *appears* as if everything is intact, but I’m also green to the 80. Which is why I’m concerned about running the air pump now that it’s been without it for...um...no one knows. 😂
 
Joined
Feb 5, 2019
Messages
94
Location
Southwestern AZ
Interesting info here, waiting on my overspending order from Wits End to show up before I start wrenching but taking inventory I noticed another winner on my new to me 3FE.

There appears to be zero mods to the engine, all of the air pump lines are intact as far as I can tell and I bought it in a no smog/emissions state.

However, I’m only running two belts. Even more odd to me as a newbie - am I about to jack something up when I throw all three OEM belts on?!

View attachment 2623201

As Jon Held alluded to earlier that smog pump bearing could be toast (or they desmogged). I imagine if it is seized that putting a new belt onto it won't be good. Check to see how freely it spinds before putting a belt on it.
 
Joined
Nov 16, 2020
Messages
76
Location
Fatally Flat FL
Ah, yes, for sure! If he says it, I look at it. Should have mentioned that. My first assumption was that it had an obvious disconnect, but t doesn’t.

Turns freely, no off axis play/wobble by hand turning, just a little surface rust since it’s just been sitting.

I guess my fear is that there’s just junk within it somewhere and introducing it back into the system would be bad.

We’re about to find out.
 
Joined
Dec 8, 2006
Messages
9,887
Location
New Jersey

Users who are viewing this thread

Top Bottom