1988 FJ62 LED Interior Bulb Swap Chart (2020 Edition)

Joined
Jul 9, 2018
Messages
4
Location
Nashville, TN
Hey friends.

I just finished upgrading all of my old dash bulbs, as well as cargo and dome lights, with new LEDs from SuperBrightLeds. I was using a list from an old thread on here, but most bulbs on the list were no longer in production. So...I made a new list with links, prices, colors, quantities, etc. and thought I would share with everyone. Click Here for the Chart

1988 FJ62 LED Bulb Swap Chart (2020 Edition).png
(Preview of what my chart looks like)

I ordered everything off this list and had no issues, but be aware of the notes I added to the chart. You may be required to do a little electrical surgery on the Rear Defroster LED and the H4 LED. It's easy though. Also, I'm not a big fan of the green lighting (as I think it looks old) so I went with Natural White or Warm White for all the green bulbs except 4WD and Turn Signals. Up to you though!💡

I hope this helps everyone. Let me know how it goes. I'll post pictures of mine soon on here and my FJ62 instagram.
 
Last edited:

Spook50

Skål
Supporting Vendor
Joined
Feb 16, 2005
Messages
6,535
Location
Spokane, WA
For some reason LEDs don't like to work in my A/C button. Can't for the life of me figure out why. Tried multiple, switched them around and everything but none worked.
 
Joined
Jul 9, 2018
Messages
4
Location
Nashville, TN
For some reason LEDs don't like to work in my A/C button. Can't for the life of me figure out why. Tried multiple, switched them around and everything but none worked.
Same issue here Spook. I took the original A/C bulb out, put in the LED and it didn't come on. Took it back out and looked at it, tried again, nothing. Took it back out and put the original back in, nothing. Took it back out and put in the LED one last time and BINGO it magically worked. I don't know what I did but i'm sure i'll pay for this success later lol.
 

MTB Land Cruise

SILVER Star
Joined
Jun 18, 2020
Messages
155
Location
Los Angeles
Hey friends.

I just finished upgrading all of my old dash bulbs, as well as cargo and dome lights, with new LEDs from SuperBrightLeds. I was using a list from an old thread on here, but most bulbs on the list were no longer in production. So...I made a new list with links, prices, colors, quantities, etc. and thought I would share with everyone. Click Here for the Chart

View attachment 2255308 (Preview of what my chart looks like)

I ordered everything off this list and had no issues, but be aware of the notes I added to the chart. You may be required to do a little electrical surgery on the Rear Defroster LED and the H4 LED. It's easy though. Also, I'm not a big fan of the green lighting (as I think it looks old) so I went with Natural White or Warm White for all the green bulbs except 4WD and Turn Signals. Up to you though!💡

I hope this helps everyone. Let me know how it goes. I'll post pictures of mine soon on here and my FJ62 instagram.
Great work! Would you say this list is a match for the 1989 F62?
 
Joined
May 15, 2017
Messages
450
Location
Charlotte, NC
Thanks so much for this! Just around the corner from swapping out all of the bulbs on my '88, so this couldn't have been posted at a better time
 

Spook50

Skål
Supporting Vendor
Joined
Feb 16, 2005
Messages
6,535
Location
Spokane, WA
Same issue here Spook. I took the original A/C bulb out, put in the LED and it didn't come on. Took it back out and looked at it, tried again, nothing. Took it back out and put the original back in, nothing. Took it back out and put in the LED one last time and BINGO it magically worked. I don't know what I did but i'm sure i'll pay for this success later lol.
I ordered a handful more and tried them again. Second one worked this time 😂

Nice to have an easily visible A/C indicator.

Also swapped out my reverse light bulbs. That was a considerable upgrade. I want to polish up the reverse light area of my housings now to improve the light distribution from them. Cleaning the lenses helped a bit too.

@SirBeef did you install the HVAC control light facing the rear of the assembly (ie facing towards the front of the truck) with reflective tape over the white plastic? Curious to see how well you managed to solve the light dispersion issues in that thing.

Really wish I could find a way to make that appear red too, since all my gauge lighting is red. Plus it looks like the 3022 listed on the chart is already discontinued, with the only current options coming in shades of white.
 
Last edited:
Joined
Feb 5, 2020
Messages
260
Location
Harpers Ferry, WV
So I went through and did all my lights. I skipped the ones in the shifter column cause I have to look up the wiring for those. I would like to mention that a lot of these LED bulbs are polarized +/- so you have to get them installed correctly inline. An easy way to do that on the smaller "NEO" bulbs is flip them over and touch the backsides of them to the housing and rotate them until they come on and then just flip them over and install them.

Furthermore, I guess the dimmer knob drops the voltage to low for the bulbs to work, so be aware of that. The other day I snapped on my hi-beams and I guess the knob turned a little at the same time and all the dash lights when out. Drove home with no dash lights trying to figure out how the hell the dash lights and headlights were linked to together to cause that issue, was checking fuses and relays, finally checked that dimmer knob lol :bang:.

The other issue I have is that the hi-beam indicator light is blindingly bright. I have even upgraded my headlights to JW Speaker LEDs and through in a 20ohm resistor on the indicator when I did that and still it's blinding.

Other than that, I'm extremely happy with the setup. Thank you @SirBeef for doing the leg work.
 

Spook50

Skål
Supporting Vendor
Joined
Feb 16, 2005
Messages
6,535
Location
Spokane, WA
So I went through and did all my lights. I skipped the ones in the shifter column cause I have to look up the wiring for those. I would like to mention that a lot of these LED bulbs are polarized +/- so you have to get them installed correctly inline. An easy way to do that on the smaller "NEO" bulbs is flip them over and touch the backsides of them to the housing and rotate them until they come on and then just flip them over and install them.

Furthermore, I guess the dimmer knob drops the voltage to low for the bulbs to work, so be aware of that. The other day I snapped on my hi-beams and I guess the knob turned a little at the same time and all the dash lights when out. Drove home with no dash lights trying to figure out how the hell the dash lights and headlights were linked to together to cause that issue, was checking fuses and relays, finally checked that dimmer knob lol :bang:.

The other issue I have is that the hi-beam indicator light is blindingly bright. I have even upgraded my headlights to JW Speaker LEDs and through in a 20ohm resistor on the indicator when I did that and still it's blinding.

Other than that, I'm extremely happy with the setup. Thank you @SirBeef for doing the leg work.
I'd like to reduce the brightness of my high beam indicator as well since doing the JW Speaker headlight upgrade. I'll have to double check, but IIRC I used a 30Ω resistor and it was mentioned in the thread that different value resistors would affect the brightness of the indicator. Need to make sure this is still the case when the high beams are switched on as opposed to "flash" mode though because IIRC when they're actually switched on that resistor isn't in the circuit. Hopefully I'm wrong here. Just gotta double check.
 
Joined
Feb 5, 2020
Messages
260
Location
Harpers Ferry, WV
I'd like to reduce the brightness of my high beam indicator as well since doing the JW Speaker headlight upgrade. I'll have to double check, but IIRC I used a 30Ω resistor and it was mentioned in the thread that different value resistors would affect the brightness of the indicator. Need to make sure this is still the case when the high beams are switched on as opposed to "flash" mode though because IIRC when they're actually switched on that resistor isn't in the circuit. Hopefully I'm wrong here. Just gotta double check.

yeah I’m in the thread as well. I honestly don’t think the resistor is even needed the way you and I have the wiring set up. I don’t think a little LED or normal bulb would cause a 10A fuse to pop. Unless it’s a ground fault thing.

Only reason I stuck the resistor in there is to drop the brightness down and I can’t tell difference from before or after. I’m on the verge of throwing the original bulb back in.

reminds me... I promised some more diagrams for that thread
 
Joined
Oct 22, 2020
Messages
19
Location
Eau Claire, WI
Hey friends.

I just finished upgrading all of my old dash bulbs, as well as cargo and dome lights, with new LEDs from SuperBrightLeds. I was using a list from an old thread on here, but most bulbs on the list were no longer in production. So...I made a new list with links, prices, colors, quantities, etc. and thought I would share with everyone. Click Here for the Chart

View attachment 2255308 (Preview of what my chart looks like)

I ordered everything off this list and had no issues, but be aware of the notes I added to the chart. You may be required to do a little electrical surgery on the Rear Defroster LED and the H4 LED. It's easy though. Also, I'm not a big fan of the green lighting (as I think it looks old) so I went with Natural White or Warm White for all the green bulbs except 4WD and Turn Signals. Up to you though!💡

I hope this helps everyone. Let me know how it goes. I'll post pictures of mine soon on here and my FJ62 instagram.
Where is the switch lighting bulb? I’ve found the rest but can’t find this bulb and can’t figure out how to get the “H4” switch out to change the bulb. I have the dash panel off and all the bulbs but need some help with these 2.
 
Joined
Feb 5, 2020
Messages
260
Location
Harpers Ferry, WV
Trying to remember off the top of my head. The switch light, I think, is the light above the rear wiper, defrost and antenna switches. The H4 button should pop out from the dash. You can get to the clips with the upper dash out. If I remember correctly the bulb is on the side.
 
Joined
Oct 22, 2020
Messages
19
Location
Eau Claire, WI
Trying to remember off the top of my head. The switch light, I think, is the light above the rear wiper, defrost and antenna switches. The H4 button should pop out from the dash. You can get to the clips with the upper dash out. If I remember correctly the bulb is on the side.
Thanks. I may do that if I get a chance again. Those green LEDs are bright! Now I have everything back in place and the heat doesn’t work! I’ll search threads on that.

03F2746F-A9AE-4567-82FA-1C3C1AF7A0CD.jpeg


02A8085B-9286-431B-A167-683C47188858.jpeg
 
Joined
Feb 5, 2020
Messages
260
Location
Harpers Ferry, WV

Users who are viewing this thread

Top Bottom