SOLD 1969 FJ55 Project SoCal

Year
1969
Vehicle Model
  1. 55 Series
Location
Yucaipa, California United States
Bought this from my buddy to fix but I just don't have the time (or the skill to deal with a carburetor. I'm a fuel injected guy, I can admit it).

It's a 69 with the 3 speed and manual steering but has power brakes and a dual circuit brake system that someone must have installed years ago. The split rims and old school tires hold air.

Engine appears to be rebuilt but I have no proof of that. Since I bought it last year I have done the following:
New GMB water pump
New thermostat
New radiator hoses
New 0 gauge battery cables
New dual circuit master cylinder from City Racer ( the pig came with a booster from what appears to be a 70 or 71)
New OEM belt
New OEM fuel pump and filter element
Had the gigantic fuel tank cleaned and painted at a radiator shop
Found and installed an original radiator shroud

I have been able to get it to start and idle but that's about as good as my carb tuning skills let me get. The clutch works and the transmission shifts. The brakes are not yet functional after I installed the new master cylinder because the flare fitting twisted off and I haven't had time to fix it. I have some extra hard lines that will come with it. The body has rust like all of them but it could be far worse than it is. Some of the body mounts are gone. The frame is extremely solid. It will need to be towed.

Comes with some extra parts I have collected.

These include:
Knuckle service from Cruiser Outfitters with wheel bearings
Carb rebuild kit from Keyster
Choke cable from Vintage Teq Parts
Windshield Rubber trim
Use brake drum parts in case the ones on here aren't any good.

I'm sure there are more parts that I'm forgetting. Whatever I have will go with it.

$4k OBO

20220723_085125.jpg


20220723_085130.jpg


20220723_085141.jpg


20220723_085153.jpg


20220723_085147.jpg
 
Joined
Jan 2, 2007
Messages
1,512
Location
So Cal
Interior is ugly.

20220723_085200.jpg
 

EWheeler

4 Cruisers, No Garage !
GOLD Star
Joined
Apr 5, 2008
Messages
2,187
Location
Menifee, CA
Any idea what the factory color was? Have you taken a magnet to the body to see where/if there is any bondo?
 
Joined
Jan 2, 2007
Messages
1,512
Location
So Cal
No idea on the factory color. I did take a magnet around and there appeared to be some bondo in the driver's rear quarter but the magnet still stuck, if that makes sense. It stuck harder to other areas.
 

Users who are viewing this thread

Top Bottom