Search results

  1. MoabChris

    Towing an FJ40 w TH-350 Automatic?

    There was definitely some major pucker-factor in the drive - but I had to move it. So it was either haul it, or drive it. Flat-towing wasn't an option at that point. I'm glad I hauled it - when I got it home, the radiator was half empty (water pump leak), the electrical system had multiple...
  2. MoabChris

    Towing an FJ40 w TH-350 Automatic?

    Mud Not familiar with Mudship.... what's that? I have a fairly large window of time to work work with.
  3. MoabChris

    Towing an FJ40 w TH-350 Automatic?

    Yes. I was totally clear on hauling the fj40 with the Pilot on the auto trailer. It met their requirements....surprisingly.
  4. MoabChris

    Towing an FJ40 w TH-350 Automatic?

    That's what I thought. Any cons/issues/risks from doing that? I read other places to leave it untied. Not sure why...
  5. MoabChris

    Towing an FJ40 w TH-350 Automatic?

    Tying off? Please explain - as I'm new to towing.
  6. MoabChris

    Towing an FJ40 w TH-350 Automatic?

    Alright forum experts. I have a 76 FJ40 land cruiser that I need to deliver 1,000 miles away. I trailered it on a uhaul trailer 500 miles with my wife's Honda Pilot a few months ago. Mainly because i didn't think it would make it on its own. I was in a bind and just did it. That seemed to...
  7. MoabChris

    What have you done to your Land Cruiser this week?

    Had to drill out the threads in the new water pump.... cause the thread pattern was different...sigh.
  8. MoabChris

    What have you done to your Land Cruiser this week?

    Had some issues with the radiator over flowing (was probably just the cap), but decided that the rusty ole water pump was due for a replacement. So.. New Water Pump, New Thermostat, New Upper Rad hose, New Lower Rad Hose, 2 gallons (undiluted) antifreeze, gasket goo, new gaskets, a bit of spray...
  9. MoabChris

    no mod goes unpunished - electrical issues again

    @Coolerman - PM Sent
  10. MoabChris

    no mod goes unpunished - electrical issues again

    After fighting with the cigarette lighter...it finally gave up. Here's what i found. Doesn't look like oem.... but by the charred/ broke (insulator?) ... we found the short. I put a new 20 amp fuse in and it didn't pop!! Now, any recommendations on a replacement power port. I don't...
  11. MoabChris

    no mod goes unpunished - electrical issues again

    Here's what the install looks like. The aux in and lighted power on/off switch.
  12. MoabChris

    no mod goes unpunished - electrical issues again

    that thread - exactly what I was looking for to get that Cig lighter out ! C
  13. MoabChris

    no mod goes unpunished - electrical issues again

    Pop was at the cig lighter... but it pops even with nothing in. I can't figure out how to remove the stupid thing....
  14. MoabChris

    no mod goes unpunished - electrical issues again

    1976 Fj40 landcruiser... sorry :) I also own an '11 FJCruiser ... the landcruiser's grandson.
  15. MoabChris

    no mod goes unpunished - electrical issues again

    It pops the 20a fuse now with nothing in the cigarette lighter!!!... I can't figure out how to remove the stupid thing.
  16. MoabChris

    no mod goes unpunished - electrical issues again

    here we go again. This week end - I thought, instead of just fixing some broken part of the Fj - that I would add a functional upgrade, in the form of sound. I found the NOAM n4 speaker, and micro marine amp, with just a simple aux in port. Nothing fancy, just plug the phone in and get some...
  17. MoabChris

    Aftermarket speakers, marine amp, aux only install...

    So today i installed some sound into the fj. Noam n4 Marine speakers attached to the roll cage, Pyle PLMRMP3B 4 Channel 800 Watt Waterproof Micro Marine Amplifier installed in the small open space to the right of the glove box, full wiring, a simple aux port and lighted on/off switch...
  18. MoabChris

    Wrong alternator?

    Thanks! I have to learn to trust the gauges....the low voltage and the negative amp draw while running should have clued me in that that the alternator wasn't sending power into the system. Live and learn. Now onto some more upgrades...and stuff. Replace the dead wiper washer fluid...
  19. MoabChris

    Wrong alternator?

    Sheepishly.... The alternator connection plug came undone.... Problem solved....
Top Bottom