Search results

  1. mateosar

    Engine won't rev past 2000 RPM(?)

    It is exactly that... uphill versus flat issue, if I floor it in flat ground the car behaves just fine and doesn't lack power or struggle to get RPMs. But lets say its a medium incline road, I would problably have to drop it into 1st gear since 2 gear starts loosing rpms easily
  2. mateosar

    Engine won't rev past 2000 RPM(?)

    By By that I mean if 1 put it in 1, 2 or 3 and hold the gear it will rev up to red line, not too fast but it gets there
  3. mateosar

    Engine won't rev past 2000 RPM(?)

    yeap in flat ground it has no problem revving up to red line
  4. mateosar

    Engine won't rev past 2000 RPM(?)

    I don't think so, recently I took it to an exhaust shop to repair an exhaust leak but I didn't see any dents
  5. mateosar

    Engine won't rev past 2000 RPM(?)

    I heard that before but the 93 model doesn't have catalytic converters
  6. mateosar

    Engine won't rev past 2000 RPM(?)

    4.5L 1FZ and A442f transmission
  7. mateosar

    Engine won't rev past 2000 RPM(?)

    No, no check engine light, did the paper clip thing and no error code showed up. No recent work around there but that doesn't mean the problem wasn´t there before. I have always noticed low power going uphill but the problem became more evident on this particular hill. I have replaced the MAF...
  8. mateosar

    Engine won't rev past 2000 RPM(?)

    Hi everyone, recently I was driving my 93' 80 series and I had to go up a pretty steephill so I put it in 1st gear and I noticed it was not getting any throtle response even after flooring it. The rpms just slowly went to 2000 -1900 RPM and stayed there the whole way. When I rev it in neutral it...
  9. mateosar

    Rough Idle/Mis Fire after new plugs and wire

    I had a similar issue with RPMs all over the place and a miss firing engine. Replaced MAF sensor and the issue persisted. It ended up being burned cooper leads on the ECU. You may want to open it up and see if it's ok.
  10. mateosar

    ISSUE Automatic transmission hard shifting 93 VX 80 Series

    Hi everyone, Some background on the car. Recently I bought an 80 series Land cruiser with a couple of issues mostly electrical. The first problem was the 1fz engine was having trouble holding idle which ended up being an issue with the ECU having burned leads. Now the issue I am trying to fix...
Top Bottom