Search results

  1. B

    New engine harness, now won’t start

    Welp, changed out all the plugs and compression tested each cylinder. All plugs were pretty oil soaked and only 1 cylinder was over 150 psi. Most were around 110-120 and cylinder 6 is around 40 psi. Dun dun dun…
  2. B

    New engine harness, now won’t start

    All of this just to get back to a misfire on cylinder 6 hahaha. I’m sure the plug is beyond fouled at this point
  3. B

    New engine harness, now won’t start

    Moved on to the starter connector, reading 12V so I reconnect it and crank it right up. Must have been something with the NSS. My dumbass must have had it in the wrong position or something. I knew it would be something stupid and easy
  4. B

    New engine harness, now won’t start

    The black and white wire under the dash is just hiding behind that orange wire. I just checked pin 6 on the NSS connector again and I do in fact have 12V like I should.
  5. B

    New engine harness, now won’t start

    Looking at that last diagram you sent, Gummy, there’s no way I shouldn’t have power at pin 5 or 6 on that NSS connector. Is it possible I could have a bad or worn out ignition switch? Is that a dumb question?
  6. B

    New engine harness, now won’t start

    I understand the NSS could be faulty or not adjusted correctly but I’m not seeing any voltage at pin 5 or 6 on the harness at that connected to even give power to the NSS itself. That connected is part of the engine harness I changed out. Testing for power the way I did at all other...
  7. B

    New engine harness, now won’t start

    Ok, update…I’m not getting any power at pin 5 on the NSS connector nor am I getting power at the starter. However…I gave direct power to the starter with the key on and the truck runs. I don’t understand how I’m not getting any voltage at the NSS connector with power at IH1 but at least the...
  8. B

    New engine harness, now won’t start

    1 day. I had the harness out and back in the same day. Finished connecting everything the next day but it was in place the same day and I ran out of light. I did check pin 6 at the connector unplugged from the NSS. So do I need to do the same but pin 5 instead?
  9. B

    New engine harness, now won’t start

    I think you guys are right and it’s something simple that I overlooked. I would say it’s not the NSS but it was gunked up and then removed to be cleaned so now it’s totally possible that could be it. I’ll check the starter for power and back to the NSS tonight hopefully. Wish it was off today to...
  10. B

    New engine harness, now won’t start

    Ok, was able to check pin 21 on IH1 in the start position and I’ve got 12V. So…wtf
  11. B

    New engine harness, now won’t start

    Looking at the diagram has me a bit confused. Here it is so you understand what I’m seeing. If my NSS isn’t seeing any power, how are my turn signals, wipers, etc working? I went back and disconnected all the connectors that run in through the firewall and inspected them and they seem...
  12. B

    New engine harness, now won’t start

    I’m definitely not getting a thump or any noise from the starter at all. I’ll look at my IH1 and see if it didn’t get a good connection for some reason. It is kinda hard to get back there but I know I attempted to snap them in place haha
  13. B

    New engine harness, now won’t start

    Tom, thank you for your reply and detail. I will definitely check this things and work my way up the circuit. Definitely want to thank everyone who has chimed in as well. This is always such a helpful forum and it’s very much appreciated. Hard to believe this has been such a fiasco from a...
  14. B

    New engine harness, now won’t start

    I tested for voltage at the AM1 relay and I’m getting 12.7 volts so the fusible link should be good, correct? I bought a new one anyway. The only connector I disconnected from the starter is that small push on connector. I never removed the cable going to the starter
  15. B

    New engine harness, now won’t start

    Checked pin 6 on the NSS with key to start and I’m getting no voltage at all. I have a new fusible link coming in today so I’ll be able to rule that out but I don’t think that’s the issue anyway.
  16. B

    New engine harness, now won’t start

    I did not but perhaps tomorrow I can get some help from my gf turning the key while I check that pin
  17. B

    New engine harness, now won’t start

    After reading another thread in which they stated the neutral safety switch as their problem, I decided to check mine out. It was disgusting and had bits of the old connector broken off in it. Cleaned it ip nice and got it installed back on the truck and connected. That did not fix the...
  18. B

    New engine harness, now won’t start

    I printed this from the electrical service manual yesterday to check but I hate this daylight savings junk. The truck is in my driveway and I don’t want to mess with it when I get home from work and it’s already dark. Gonna have to suck it up and check that circuit. I think you’re definitely right.
  19. B

    New engine harness, now won’t start

    I guess what I need to figure out is what connections of the harness would prevent the truck from cranking. Connection to the starter, ground…knock sensor? Bad main relay? I could get a new fusible link just to get one but I believe mine is still good
  20. B

    New engine harness, now won’t start

    Well, I was gonna send a video but seems like a pain to do. Yes, check engine light is on with the key in the on position and so is the battery light. No crank whatsoever and like I said before, all connectors are connected and accounted for. There is one connector that runs to the starter...
Top Bottom