Recent content by uk55

  1. U

    Power steering long tube rusted - will it go in/out in one piece ?

    Thanks folks, will take the rad out at the weekend. And thanks for the paperclip offer @Danger Cruiser but I'm the UK so postage costs and time leads me to try making one up from the bit of right size pipe I have laying around. Always a great community here.
  2. U

    Power steering long tube rusted - will it go in/out in one piece ?

    Power steering dumped its fluid and the leak is the hard tube loop rusty under the radiator. Can it be removed and replaced with a new one in one piece. Tried at the end of today to get it out without success yet. Whats the secret ye experienced ones please ?
  3. U

    Brakes weak and weird

    Is a service kit for the master available ? (I'm in the UK)
  4. U

    Brakes weak and weird

    The fluid hasn't dropped at all since I bled it a month or two back, but i did notice it was low when she had sat around before that. I'm guessing that was due to the rear cylinders leaking which I now replaced. (and when I pump the pedal comes higher but the brakes feel weaker) When I...
  5. U

    Brakes weak and weird

    Hi Folks, My 60 has laid off the road for quite a while, drove it today and there is no feel in the brakes, if I press hard I can stop and lockup one of the wheels, the pedal feels a bit low when pressed. If I pump the pedal it comes to the top but then the brakes are even weaker. Does...
  6. U

    Can you still get these wheel nuts?

    I looked for these in the UK without success. My 60 has alloy wheels by Haslbeck that don't seem to be in business anymore as wheel makers. The steel washers that fit in the wheel have a taper on both sides, to match the wheel nut socket and the nut. I'd like to keep the wheels but...
  7. U

    Broken loom wire, how to fix

    FIXED !! @Seth S and @2mbb and others elsewhere thanks for your awesome help with this, after an embarrassing years of living and trying with this problem on and off it was simply a red 'stop' wire break at the loom connector to the EDIC motor in the engine bay. It was almost a non Toyota...
  8. U

    Broken loom wire, how to fix

    Ha ha, thanks Felix, see how I go, it might end up ugly but will try for pretty first.
  9. U

    Broken loom wire, how to fix

    OK thanks @Seth S and @2mbb I will try and eject the connectors in the morning and try and source them. I'm in the UK but guess I could still order them from @ToyotaMatt if I can't get them over here ? 2mbb you've reminded me I might have a wire break detector somewhere from telephone work...
  10. U

    Broken loom wire, how to fix

    Thanks Seth, see pics, in the footwell its the one in my hand, and in the engine bay its the female of the one you see ( a very difficult one to get near)
  11. U

    Broken loom wire, how to fix

    I think I finally found the cause of my won't turn off problem. There's no continuity in the 'red' wire from the loom to relay plug in the driver footwell (RHD) to the EDIC motor loom plug in the engine bay. This is the 'stop' wire. Question is how do I fix it? From what I can see the...
  12. U

    Diesel 60 series EDIC problem - can I test the relay ?

    Doh, thought I'd found the problem but no. (changed a faulty oil pressure switch). Does anyone know how to test the EDIC relay please? I have two relays but the fault is the same with both. Everything on the 'over inject phase' works and I tested the EDIC motor on the bench last year.
  13. U

    Diesel 60 series EDIC problem - can I test the relay ?

    Hi All, Having another go at fixing my 'wont turn off' problem. Last year I took the EDIC motor off and it tested Ok on the bench on a battery, going through its cycles. I bought a second hand EDIC relay from a breaker (condition unknown) and that made no difference. Both relays look OK...
  14. U

    HJ60 wont switch off

    Thanks.if i push the arm forward the engine stops. the arm on the motor is not moving at all .i took the motor off tested on a battery, its fine, does what its supposed to. I opened the relay (in the foot well ) its clean, contacts are fine. I need some more pointers re the relay maybe...
  15. U

    HJ60 wont switch off

    Ok im still struggling with this. I took the motor off and checjed it on a battery and with a volt meter and its ok. I opened up the relay in the footwell and its all clean inside. Cleaned up its mount to the body, and cleaned the chassis to gearbox earth. Also have two new batteries on...
Top Bottom