thelal
Reactions
122

Latest activity Postings Media About Badges Post areas

    • thelal
      thelal reacted to gnarlynick2072's post in the thread Builds My GCC Spec FZJ100 with Like Like.
      So this project just got huge. Hence the delay in posts. I have a habit of "while you're in there" work, and boy oh boy, I found a lot of stuff to do while I'm in there. So I pulled absolutely EVERYTHING from the engine bay. It was filthy, and...
    • thelal
      Fans and lights - nice
    • thelal
      One-Week Update. May jinx it but I’m posting, regardless. Typically I would’ve had at least a Pending by now.
    • thelal
      thelal replied to the thread Harmonic balancer fail?.
      I'm a FeBest in mine ; Only been in a few weeks with very little mileage covered. Seems fine
    • thelal
      thelal reacted to spressomon's post in the thread Lithium Starter Battery with Like Like.
      Be sure to augment, assuming your alternator and/or regulator can't output ~14.6v to properly charge the Odyssey, with a capable shore power (or solar) charger. This charging strategy when the rig sits in the driveway/garage, will pay dividends...
    • thelal
      thelal reacted to Escape Artist's post in the thread Lithium Starter Battery with Like Like.
      UPDATE: My Dakota Lithium start battery is now toast. Here’s a valuable learning experience that I wouldn’t mind sharing if it saves anyone else the trouble. This battery will accept as much charge as the alternator will give out, being that I...
    • thelal
      thelal reacted to Escape Artist's post in the thread Lithium Starter Battery with Like Like.
      I just put the 130 amp hour lithium iron phosphate deep cycle dual purpose battery as my start battery. Here’s what I found out so far, the BMS system will prevent the battery from charging at below freezing temperatures, but it will start the...
    • thelal
      thelal reacted to gummycarbs's post in the thread Hard start when hot with Like Like.
      I did this. It's a pain because you have to remove a banjo bolt at the back of the fuel rail. The engine wiring harness is in the way, making it a bit stressful when you're trying not to cross-thread the adapter. What it will tell you is...
    • thelal
      Hi , I see that you are in Europe refurbishing your rig . Beware that in Europe there are strict laws on gross weight of vehicles , and driving licenses allowed to drive them . General rule is 3500 kg for a standard vehicle fully loaded . And it...
    • thelal
      thelal reacted to BILT4ME's post in the thread Harmonic balancer fail? with Like Like.
      Up to this point, there have been few failures. However, as these trucks age, the rubber products get heat soaked, oil soaked, and have been in service for 24-30 years and may have over 300K miles on them. Most of us have already been replacing...
    • thelal
      The sensor extender won't "fix" it, just keep the sensor from measuring as much change in oxygen levels. I'm wondering why you believe it would be the downstream cat. Typically, the upstream cat is the reduction portion, which contains the...
    • thelal
      Wished you lived close. I'd weld that up for you. Others have reported pretty good long-ish lasting results. If you can remove that section, a muffler shop will weld that up for you easily too.
    • thelal
      Standard MIG welder with .030 wire. Had to build up the weld to get everything sealed since that's a deep crevice.
    • thelal
      Popped the Y-pipe off. One of the nuts spun but I got it off. It boogered up the stud threads then the stud would not come out so I went ahead and took off the front exhaust manifold. Much easier to get the stud out when it’s on my bench (torch...
    • thelal
      thelal reacted to CycloSteve's post in the thread grab bar install with Like Like.
      Here is what I am coming up for the earlier dash styles. YMMV. 74670 GRIP ASSY, INSTRUMENT ASSIST 74670‑60010‑03 BLUISH GRAY, TRIM1* 1 $94.18 74670‑60010‑06 SABLE, TRIM4* 1 $90.18 The overhead console is also used for the Subtank, which...
    • thelal
      thelal reacted to gofast's post in the thread Tilting fridge slide options? with Like Like.
      My Destaco arrangement
    • thelal
      Well to recap, the space from the sensor to the rotor should only be about a millimeter. I checked all the wiring, and sensors. Pulled the right wheel and rotor off, had the large gap like original poster shows. Sensor and wires checked out...
    • thelal
      I used gumout type exhaust paste for years ; would last several weeks. easy to put on but gets old
    • thelal
      That is a very tough place to fix. The only chance to get it is with the pipe on the bench. That material is very difficult to weld. That is if it's a stock pipe.
    • thelal
      thelal reacted to Dullyouth's post in the thread Harmonic balancer fail? with Like Like.
      Mine went bad about 3 years ago. I have a post on here about it and some YouTube videos. Fortunately it was a slow failure. UPDATE ( Harmonic Balancer failure ) Cold idle stumble 1fz -...
    • thelal
      I experimented with different degrees of initial advance and used my electronic stethiscope to listen in on knock, i found whilst running 91 octane(opal fuel) and anything from 6-12° of advance the engine did not ping, but soon as i went over 13°...
    • thelal
      thelal reacted to Dave Pierce's post in the thread 97 1fzfe knock with Like Like.
      Was involved in a AMC dealership years ago and we had problem with engine knocks on the top end of the inline 6 cylinder motors, the cause was carbon build up on top of the cylinders, a piece would break off and you could hear it knocking around...
    • thelal
      Thanks for everyone’s input. I’ve disconnected the factory amp, which drastically improved sound quality as well, and I’m running power to it on its own circuit via my new Blue Sea fuse box. No issues since disconnecting factory amp though.
    • thelal
      Yep, the problem happens when you bypass the factory amp. The amp stays powered on, and it stays connected to the speakers unless you unplug it. Both amps see each other as a zero-ohm load, which explains the "PROTECT" mode activating.
    • thelal
      Hi all, been a while since I've posted anything, so I figured I'd post my troubleshooting process for what turned out to be a bad EFI Relay for posterity's sake. Maybe this'll help someone in the future. Patient: 1992 FJ80 3FE Location...
  • Loading…
  • Loading…
  • Loading…
  • Loading…
  • Loading…
Top Bottom