87 fj60 won't idle

Discussion in '60-Series Wagons' started by SharpasMarbles, Jun 2, 2012.

  1. SharpasMarbles

    SharpasMarbles

    Messages:
    91
    Location:
    Chesapeake, Va.
    Started trying to bring the old girl back to life, she's been sitting for quite some time, replaced the choke cable and battery.....drained the tank and added 10 gallons of fresh 93 octane, got it to start but will only stay running when choke is engaged, runs and went for a drive around the block seems to drive ok.....but when I take push the choke cable to the off position it dies....it stumbles a little bit but then dies, engage the choke and it will fire right back up......no idea where to start with the idle issue.......got front brakes done today and am trying to figure out which way to go with the suspension...any help will be greatly appreciated......thanks Monty
  2. Spike Strip

    Spike Strip SILVER Star

    Messages:
    9,234
    Location:
    Right behind you.
    Do a search for ICS or Idle Control Solenoid or variations of that.
  3. 60 toy ota

    60 toy ota

    Messages:
    340
    Location:
    Davis County, UT
    x2, theres a lot of threads about the ics
  4. Check EGR valve just to make sure it is working. That might have froze up in the open position (or slightly open).

    A vacuum reading will indicate vacuum leak on this. Richer mixture due to choke overcomes that vacuum leak.

    Note that a sticky valve will pass the factory manual egr valve test, so don't count on that to see if there is a problem there.

Share This Page